What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion xteve plex recording #issue

Assists Greatly with Development Costs

turner123

Respected Member
Donor
PG Version
8.6.1
Server Type
Remote - Dedicated Server
I have setup xteve with my plex all is great and its pretty amazing but a small issue is

When recording it starts off in /mnt/downloads/tv in a folder .grab/728569283rgif72347ye8732iyqr23yiqwd for eg
This then gets renamed i assume by plex and the epg into folder sky news/the-date-episode/ here should be the .ts file
plex has scanned found the show but when play fails as the folders exist still but the file 728569283rgif72347ye8732iyqr23yiqwd/show.ts has been moved to the trash.

any ideas or suggestions as to why this i happening?
 

turner123

Respected Member
Donor
Figured it out

Using mnt/unionfs/recordings
Resulted in a file called .grab/sjdufuriwksncnforowoeucnnf/recording.ts
This was then sent to the correct place along with 2 folders of show name and season that remained in the correct dir but the ts file was always deleted in gsuit

BUT if I used dir mnt/tdrive/recordings works perfect everytime


So it has to be a permission issue with sending with gdsa members
 

LckyLuciano

Junior Member
You need to add an exclude entry to your move.sh script. I had the same issue but am now able to record OK. It was pulling things out of the .grabs folder before they were ready to be moved. Make sure this is in there next to your other exclude entries in the script.

Code:
--exclude="**.grab/**"
 

turner123

Respected Member
Donor
You need to add an exclude entry to your move.sh script. I had the same issue but am now able to record OK. It was pulling things out of the .grabs folder before they were ready to be moved. Make sure this is in there next to your other exclude entries in the script.

Code:
--exclude="**.grab/**"
Only just got the time to have a look at this now, but where is move.sh file? iv found the pgblitz.sh that has similar excludes inside am i right in thinking its that one?
 
M

MrDoob

Guest
Yes the same ..

But you must stop the service first before you edit any line

sudo service pgblitz stop
sudo service pgblitz status
then q
kill {PID}
( pid are the numbers of running services || left side the 4 - 5 numbers )

then

cd /opt/appdata/pgblitz
cp pgblitz.sh backup.pgblitz.sh
nano pgblitz.sh

If your update or redeploy the mounts, it will be removed

If you save the file

sudo service pgblitz start


@Admin9705 add

Bash:
--exclude="**.grab/**"
In PGMove and PGBlitz
 

shmookles

Full Member
Yes the same ..

But you must stop the service first before you edit any line

sudo service pgblitz stop
sudo service pgblitz status
then q
kill {PID}
( pid are the numbers of running services || left side the 4 - 5 numbers )

then

cd /opt/appdata/pgblitz
cp pgblitz.sh backup.pgblitz.sh
nano pgblitz.sh

If your update or redeploy the mounts, it will be removed

If you save the file

sudo service pgblitz start


@Admin9705 add

Bash:
--exclude="**.grab/**"
In PGMove and PGBlitz
Has this been added into the main code or do we still need to make these exclude change for xTeVe?
 

shmookles

Full Member
Thank you @MrDoob now if we could just get the container to pull the latest version of 1.4.4 instead of the 1.1.0 it currently does... :)

How do I merge this fix into my install?
 

shmookles

Full Member
and it will just work without any further mods? I will try it. But why not just fix the app? The current repo doesn't even work with the old version. I loaded a custom container with xteve and it works... im sure im not the only one with these issues.
 

Porkie

Senior Member
Staff
I don't see why it wouldn't work, its just a container with the same values, all the problem is that the repo isn't updated which you can do yourself if you have a little docker knowledge. It doesn't take much. Its the same for most docker images that you can switch around repos as long as the paths/ports match which most do and even then if they don't you can just edit the path/ports quite easily.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
14
Guests online
104
Total visitors
118
Top