What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Update 8.6.5 mergerfs

ink0gnito

Full Member
PG Version
8.6.5
Mount Type
Move Encrypted
Server Type
Remote - Dedicated Server
Hello i have updated PGBlitz from 8.6.4 to 8.6.5 with the newer mergerfs.
After that i didnt have any mount on /mnt/unionfs.
The output from systemctl status pgunion.service: failed
Jun 10 18:15:44 plex systemd[1]: Started PGUnion.
Jun 10 18:15:46 plex bash[15256]: fuse: unknown option `atomic_o_trunc'
Jun 10 18:15:46 plexx systemd[1]: pgunion.service: Main process exited, code=exite
Jun 10 18:15:46 plex systemd[1]: pgunion.service: Failed with result 'exit-code'.
 

Admin9705

Administrator
Project Manager
No problem. It takes time to rebuild all the packages I support but I'll have a 2.28.1 uploaded in a bit.
updated your titles lol. Good to see you again. You've been doing some great work.
 

mondychan

Junior Member
can you please give guidance to the rclone variables? i may have fiddled with it in the past and those could be wrong for the current setup :


3487


thanks guys for your hard work as always!
 

introvertmouse

Senior Member
can you please give guidance to the rclone variables? i may have fiddled with it in the past and those could be wrong for the current setup :


View attachment 3487


thanks guys for your hard work as always!
Unless someone has a different opinion, if it aint broke dont fix it. I have been using the defaults with no issues. I may seen a thread or two were some made some mods to it but I rather not touch if working.
 
T

TheShadow

Guest
I would turn off cache mode, unless you use bazarr or something that requires that mode.

Buffer-size can be increased, I recommend a max of 1G but you need at least 16G of ram to be safe. Buffer-size is dependent on amount of free RAM, this limit is per file. So if you got 8gb or less, don't go over 128M.

Read-chunk-size can be 32M-128M depending on what you mostly playback (bitrate wise, and if direct play)

If you actually go into the options, there's helpful info to help you make a decision.

Test your values using Direct playing high bitrates vs low bitrates, as direct stream or transcoding aren't really affected by these values too much.

The PG defaults should work for most people.
 
Last edited by a moderator:

mondychan

Junior Member
I would turn off cache mode, unless you use bazarr or something that requires that mode.

Buffer-size can be increased, I recommend a max of 1G but you need at least 16G of ram to be safe. Buffer-size is dependent on amount of free RAM, this limit is per file. So if you got 8gb or less, don't go over 128M.

Read-chunk-size can be 32M-128M depending on what you mostly playback (bitrate wise, and if direct play)

If you actually go into the options, there's helpful info to help you make a decision.

Test your values using Direct playing high bitrates vs low bitrates, as direct stream or transcoding aren't really affected by these values too much.

The PG defaults should work for most people.
thx a lot, i didnt notice (blind me) the notes under each option!
its explained there very precisely + your info, great ! thx again
 

hawkinzzz

Full Member
Generally, if i ever update anything I always redeploy PGClone. I did it automatically not thinking about it and have not had any issues upgrading to 8.6.5. I only realized you 'had' to redeploy it after and I was just browsing the forums :LOL:
 

pb1051

Respected Member
Redeploy pgclone, as the configuration needs updates.
I've done the same update and then redeployed pgclone, but Plex it not finding any files in /mnt/unionfs/. I can see that they are still there, but Plex if having trouble seeing them. System was running fine for two months until this update.
 

Admin9705

Administrator
Project Manager
I've done the same update and then redeployed pgclone, but Plex it not finding any files in /mnt/unionfs/. I can see that they are still there, but Plex if having trouble seeing them. System was running fine for two months until this update.
Reboot the system.
 
T

TheShadow

Guest
That doesn't make sense. If /mnt/unionfs had your files, then restarting the plex docker image should have worked. Did you make any custom edits to your configs? It seems that seems likely based on what you did and what you describe.
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
9
Guests online
515
Total visitors
524
Top