What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Traefik failing deployment upon portainer check

Reconos

Junior Member
PG Version
8.7.5
Server Type
Local - Virtual Machine
Whelp, i need some help, or some ideas where to look.

I have been using PGblitz for almost 6 months now without any mayor problems, except for the ones i've made myself, but now im pretty damn lost on how to continue.

Here's a bit backstory on the problem.

Im running the server on an oracle vm, hosted at home on my own server.
About a week ago, i decided to move my PG from an ubuntu 18 with GUI, to an Ubuntu 18 Server.
- I backed up everything throu PG on the old server.
- Shut the old server down
- installed a new, with same IP as the old one
- installed PG
- setup PGmove with correct information
- Installed the same apps as the old server had.
- installed the backups
- ran Traefik setup (it didn't give me any errors on this deployment)
- Setup Oauth (Found out yesterday that i have been using wrong app id and secret)
- Secured with Port Guard

Now, everything seemed fine, and i was happy as i could be, the move seemed to be a success.

2 days ago, i noticed upon logging in to the terminal, that traefik told me it wasn't deployed correct. But, i could without any problems visit all of my subdomains, without cert errors.
As i didn't want to see the error message everytime i logged in, i decided to redeploy traefik.

1st time - Failed after passing the initial 60+10 seconds wait and redeploying portainer
2nd time - Failed after passing the initial 60+10 seconds wait and redeploying portainer

Throu Pgblitz i was told to pull both pgbox: core and and pgbox: community, and then redeploy

3 time - Failed after passing the initial 60+10 seconds wait and redeploying portainer
4 time - checked that every setting in traefik was looking right, double checked the api key and secret from my godaddy account. - Failed after passing the initial 60+10 seconds wait and redeploying portainer

Now im awaiting the "Too many certificates already issued....." "ban"

Where should i look to see if i have made any mistakes? I haven't changed anything manually outside the PG scripts
 

Reconos

Junior Member
Portforwarding hasn't changed between moving servers, and port 9000 is not forwarded, only 443, 80 and 32400
During the deployment, i can access portainer.domain.dk, and get the cert error. but the site is accessible, until it fails the deployment
 
Assists Greatly with Development Costs

Reconos

Junior Member
this is the error traefik throws me whenever i try to deploy a duckdns domain:
Code:
time="2019-08-03T12:49:45+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
time="2019-08-03T12:49:46+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-14. Skipping frontend frontend-Host-oauth->redacted<-dk-14...",
time="2019-08-03T12:49:56+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
time="2019-08-03T12:49:57+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-14. Skipping frontend frontend-Host-oauth->redacted<-dk-14...",
time="2019-08-03T12:50:51+02:00" level=error msg="Unable to obtain ACME certificate for domains \"rvtest.duckdns.org\" : unable to generate a certificate for the domains [rvtest.duckdns.org]: acme: Error -> One or more domains had a problem:\n[rvtest.duckdns.org] acme: error: 403 :: urn:ietf:params:acme:error:unauthorized :: Incorrect TXT record \"parrNEjtqIdKhjl2V9udczlzSBVGnWB4gPafdPLSgN4\" found at _acme-challenge.rvtest.duckdns.org, url: \n",
time="2019-08-03T12:50:56+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-14. Skipping frontend frontend-Host-oauth->redacted<-dk-14...",
time="2019-08-03T12:50:57+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
time="2019-08-03T12:51:00+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-14. Skipping frontend frontend-Host-oauth->redacted<-dk-14...",
time="2019-08-03T12:51:00+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
time="2019-08-03T12:51:01+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-13. Skipping frontend frontend-Host-oauth->redacted<-dk-13...",
time="2019-08-03T12:51:06+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
time="2019-08-03T12:51:07+02:00" level=error msg="undefined backend 'backend-oauth' for frontend frontend-Host-oauth->redacted<-dk-14. Skipping frontend frontend-Host-oauth->redacted<-dk-14...",
time="2019-08-03T12:51:59+02:00" level=warning msg="unable to find the IP address for the container \"/oauth\": the server is ignored",
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
13
Guests online
100
Total visitors
113
Top