What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Traefik deployment fails even though portainer.domain.com is valid

SuchPotential

Blitz 3rd Class
PG Version
8.5.8
Server Type
Local - Virtual Machine
Hello all!

I've been puling my hair out for the past few days trying to figure this out and I can't seem to find something that addresses my issue here on the forums (the website URL change doesn't help either) so I thought I'd give a new post a shot.
I have my domain through CloudFlare and as far as actually accessing my services via {app-name}.domain.com that works just fine, but each new page warns me of an insecure cert because I simply cannot get the Traefik module to properly deploy. I've got my DNS records on CF all right as far as I can tell, and every other setting (that doesn't rely on traefik to be deployed) works as expected, so I'm really stumped here.

A little about my setup: I've got a home server running Debian, and PlexGuide running on a VM (Ubuntu 18.04 LTS).
I have ports 80 and 443 forwarded from my router to 8080/8443 on the physical box, which are then forwarded to 80/443 on the VM running PG.
As stated above, all requests to {app-name}.domain.com are going through to the correct services, albeit with the insecure cert warnings.
When I try to deploy Traefik through the PlexGuide CLI, it gets to the Portainer verification page and fails every time.

I've tried to address the points that the CLI tells me may be the issue, but I can't seem to pinpoint where the issue is rooted.

Any help on this is greatly appreciated,
Thanks!
 

foolio

Blitz 1st Class
Patron
not sure this will help you but I am running on local server with a ubuntu vm 18.04 as well. It is working fine the only difference in my setup and yours that I can see is that I configured my router/gateway to forward directly to the ubuntu vm running plexguide and forwarded the ports 80/443 and 32400 the vm has a static ip on my network. I am also running on top of ESXi (Vsphere) instead of a vm in ubuntu.
 

Maslygan

Blitz 1st Class
Donor
Where did you take the api key from in cloudflare? i just figured out that i have to find it under my account(rightclick at the top right corner), and not api where it says zone id and account id on the front page, lmao... xD
 

SuchPotential

Blitz 3rd Class
I tried routing the ports directly from the router to the VM, and my domain resolution stopped working..

I took the API key from my profile page and not the domain page, but I checked again to make sure.

No difference :(
 

mikey

Blitz 3rd Class
having similiar issue, portainer.domain.com loads just fine, yet traefik fails to deploy... :(

EDIT***

Seems like changing servers nameserer entries resolved my issues.

For ubuntu 18.04 I used this guide to adjust nameservers:

rebooted, and traefik validation worked fine.

Hope that helps someone.
 
Last edited:

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Top