What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Traefik deployed correctly but cannot access domain from outside LAN

agentchromatic7

Blitz 3rd Class
PG Version
8.6.4
Server Type
Local - Virtual Machine
Hey all. Extreme newbie to PGBLITZ, UBUNTU, and Traefik. I tried searching for my issue, but couldn't find anything that was helping me out. As of right now, I am using VMWARE workstation to use ubuntu, and I set up a bridged static IP like what was talked about in the video from PGBLITZ for VMWARE Workstation. I'm using GoDaddy, I am able to access all domains on the LAN, and I have all ports closed using PG Shield with PGSHIELD working as well.

However, I cannot access my domain from outside the network. I see talk of forwarding ports, but I don't know how that would help if PGSHIELD is blocking my ports. I'm not too keen of opening all my ports in order to get it to work.

I'm not sure what i'm missing here, but I would be extremely thankful for some guidance. I'm just at a complete loss as to what to do. I believe that it may either be my ISP blocking port 80 or something weird going on with VMWARE preventing access. Maybe changing the ports on the VM or Ubuntu would help? However, I don't know how to go about doing that to test.

Please let me know what information you all need in order to better assist. I feel like i'm close to getting it to work, but i'm missing something simple and its gnawing at me.
 

MrDoob

Administrator
Project Manager
Donor
Simpler test for local and remote if port open/closed

timeout 1 bash -c "</dev/tcp/google.com/80" && echo HTTP = Port 80 open . || echo HTTP = Port 80 closed .

timeout 1 bash -c "</dev/tcp/google.com/443" && echo HTTPS = Port 443 open. || echo HTTPS = Port 443 closed

timeout 1 bash -c "</dev/udp/google.com/22" && echo SSH Port 22 open. || echo SSH Port 22 closed


Try this inside the terminal :p
 

agentchromatic7

Blitz 3rd Class
Simpler test for local and remote if port open/closed

timeout 1 bash -c "</dev/tcp/google.com/80" && echo HTTP = Port 80 open . || echo HTTP = Port 80 closed .

timeout 1 bash -c "</dev/tcp/google.com/443" && echo HTTPS = Port 443 open. || echo HTTPS = Port 443 closed

timeout 1 bash -c "</dev/udp/google.com/22" && echo SSH Port 22 open. || echo SSH Port 22 closed


Try this inside the terminal :p
It says 80 443 and 22 are open. So that's good to know.
 

PonsterManda

Blitz 3rd Class
Sounds like your modem/router is blocking the port (As it should be, thank god)
You could port forward to the ip of your virtual machine.
I would recommend to set this up only for port 443 (https).
Portforward 22 (ssh) would grant access to the terminal of your vm from the outside. Thats a security risk.
 

agentchromatic7

Blitz 3rd Class
Sounds like your modem/router is blocking the port (As it should be, thank god)
You could port forward to the ip of your virtual machine.
I would recommend to set this up only for port 443 (https).
Portforward 22 (ssh) would grant access to the terminal of your vm from the outside. Thats a security risk.
3521

This is what I have already. I have 443 point to my VM. I'm using Merlin on my ASUS RT-AC86U router. I think I have it forwarded correctly. Do I need to re-deploy traefik in order for it to take?
 

MrDoob

Administrator
Project Manager
Donor
You need to open 80 and 443 for the internal ip
And fixed up for the local server

For plex the same
Open port 32400 for listings over the network
 

agentchromatic7

Blitz 3rd Class
You need to open 80 and 443 for the internal ip
And fixed up for the local server

For plex the same
Open port 32400 for listings over the network
I think I get what your saying. Is the below screenshot what you're talking about? The ports are being forwarded to my static IP i set up on the VM.

3522
 

MrDoob

Administrator
Project Manager
Donor
You must specify the local IP

I think in you case is it source the local IP
 

agentchromatic7

Blitz 3rd Class
You must specify the local IP

I think in you case is it source the local IP

Is it

Internal IP Address = VM Static
Source IP Address = VM Static

or

Internal IP = Host Machine IP
Source IP = VM Static

Neither of those combinations worked. I also tried

Internal IP = VM Static
Source IP = Host Machine

I'm not sure if this is an issue, but when I go to check the connected client on my router page is shows there are 2 connection for the host machine, but shows my static IP in the VM as the main IP. I also can't ping the host machine IP address, which is odd correct?


I don't think my bridge connection is working properly. Its supposed to make it look like its a totally different machine on the network. Not sharing the IP with the host machine, correct?
 
Last edited:

MrDoob

Administrator
Project Manager
Donor
Local is sometimes a problem ..

You use a router in a bridge mode *?*
 

agentchromatic7

Blitz 3rd Class
This guide is good, but most of the stuff in here PGBLITZ already does for us. I have to the correct A records because I can get to the domains and it says traefik is deployed with no errors. I feel like the problem lies somewhere else, but I have no clue. The router maybe? I may get another machine and just install Ubuntu as the base OS on it and see if that changes anything. I'm stuck and have no clue why I can't access it from the outside. I followed all the guides and it should be working.

A friend of mine did the same thing (followed all the pgblitz guides) and its worked with no issue. Only difference is he has a dedicated machine running Ubuntu and PGBLITZ. I think the issue it that the VM is not being recognized as a separate machine and sharing the same IP address as the host machine and its creating this weird issue.

I dunno. I'm at a loss. Going to have to use my shitty laptop and try to run ubuntu on that and see if I get the same issue.
 
Last edited:

deva5610

Blitz 3rd Class
Donor
Donor
Source IP Address =
Source IP is the external IP address/s you want to be able to connect in to that port. So if you're only going to be connecting from a specific machine that has a static IP, you'd put it there. If you want to allow access to that port from any device you leave it blank. I'd leave it blank for testing - it's one less thing that can be incorrectly configured.


Internal IP = Host Machine IP
I would guess this is the correct way to set up the internal IP, but I've not worked with VMWare, so it is very much just a guess.
 

fr0sty

Blitz Sergeant
Staff
Donor
VMware is easy, it's just like running bare metal.

1. Open vmware, edit VM settings and look at the mac address of the VM under network.
2. Go to router and set static ip for that mac address.
3. Forward ports 80, 443 to that static.
4. Restart VM
5. Type ifconfig in pg-box to confirm new static IP.
 

agentchromatic7

Blitz 3rd Class
VMware is easy, it's just like running bare metal.

1. Open vmware, edit VM settings and look at the mac address of the VM under network.
2. Go to router and set static ip for that mac address.
3. Forward ports 80, 443 to that static.
4. Restart VM
5. Type ifconfig in pg-box to confirm new static IP.
I just tried to do what you said and something odd showed up. The MAC address that the VM is supposed to have, does not show at all on my router page/devices connected section and it will not let me add an IP by MAC. No error message, but it just resets the screen like nothing happened after loading for a bit.

Also, when I do ARP -A on the host machine the static IP that I set for the VM, shares the same MAC address as my host machine. I've seen others setting up their VM and when they do ARP - A or IPCONFIG /ALL it shows their VMs mac address. I'll try generating another MAC address on the VM to see if it does anything..

How is that possible?
 

agentchromatic7

Blitz 3rd Class
I just tried to do what you said and something odd showed up. The MAC address that the VM is supposed to have, does not show at all on my router page/devices connected section and it will not let me add an IP by MAC.

EDIT: I thought it wasn't letting me add, but I just restarted my router and it let me add by MAC. I'm going to see if the VM takes my IP now.
 

agentchromatic7

Blitz 3rd Class
VMware is easy, it's just like running bare metal.

1. Open vmware, edit VM settings and look at the mac address of the VM under network.
2. Go to router and set static ip for that mac address.
3. Forward ports 80, 443 to that static.
4. Restart VM
5. Type ifconfig in pg-box to confirm new static IP.

1. I re-generated the mac and then took the mac address and added it to my router assigning it an IP
2. forwarded the ports 80 and 443 to the static IP
3. Restarted the VM
4. used "ifconfig" and saw that the address has changed.

Did that, but still no communication. I did arp -a on host machine to see if I could see the MAC address of the VM and the IP i assigned to it, but the MAC in ARP -A is showing my host machine MAC address and my VM IP address. It also shows it as a dynamic IP not a static.

I'm at a loss. It should not be doing that. Should be a separate MAC address with a separate IP from the host machine.
 

fr0sty

Blitz Sergeant
Staff
Donor
Oh.... re-read OP
VMWARE workstation
Its not ESXI.. There is a setting in VMWARE workstation somewhere that "shares" host ip or assigns a new one. Have a dig around. Think its when you create the VM but might be when you edit it as well.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Trending

Top