Traefik/Cloudflare/ Portainer Check Failed

seanweldon

Blitz 3rd Class
Original poster
13
2
I'm in the process of migrating my Plexguide from a virtual hosted instance to a physical local server. I've already updated my Cloudflare DNS entries to point to my IP address, but the portainer check keeps failing.

Code:
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
🚀 Portainer Check
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

NOTE 1: Do NOT EXIT this interface. Please standby for validation checks!

NOTE 2: Checking on https://portainer.my.domain's existance.
Please allow 10 seconds for portainer to boot up.

NOTE 3: Be aware that simple mistakes such as bad input, bad domain, or
not knowing what your doing counts for 75% of the problems.

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
StandBy - Portainer Validation Checks: 0 Seconds

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
🚀 Portainer Check: FAILED!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
SMART TIP: Check Portainer Now! View the Traefik Logs!

Checking the Portainer logs-
2019/05/13 17:37:31 Templates already registered inside the database. Skipping template import.
2019/05/13 17:37:31 Starting Portainer 1.20.2 on :9000
2019/05/13 17:44:36 http error: Invalid JWT token (err=Invalid JWT token) (code=401)
2019/05/13 17:44:36 http error: Invalid JWT token (err=Invalid JWT token) (code=401)
2019/05/13 17:44:36 http error: Invalid JWT token (err=Invalid JWT token) (code=401)

Traefik Logs-
time="2019-05-13T17:37:31Z" level=error msg="Unable to obtain ACME certificate for domains \"*.my.domain\" : unable to generate a certificate for the domains [*.my.domain]: acme: Error -> One or more domains had a problem:\n[*.my.domain] acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/finalize/57007895/448434704 :: urn:ietf:params:acme:error:rateLimited :: Error finalizing order :: too many certificates already issued for exact set of domains: *.my.domain: see https://letsencrypt.org/docs/rate-limits/, url: \n"
time="2019-05-13T17:37:32Z" level=error msg="Unable to obtain ACME certificate for domains \"my.domain\" : unable to generate a certificate for the domains [my.domain]: acme: Error -> One or more domains had a problem:\n[my.domain] acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/finalize/57007895/448434703 :: urn:ietf:params:acme:error:rateLimited :: Error finalizing order :: too many certificates already issued for exact set of domains: my.domain: see https://letsencrypt.org/docs/rate-limits/, url: \n"


I guess my first question is whether Traefik not being able to get a certificate would cause the Portainer check to fail? Is there a way I can make Traefik setup for now without a valid certificate, as I'd prefer not to have to wait a week to get my instance fully up and running?

Thanks!
 

MrDoob

Administrator
Project Manager
Donor
1,393
397

MrDoob

Administrator
Project Manager
Donor
1,393
397
Maybe an DNS timeout

If you use local one.

Check the ports on your router
Check the 443 and 80 port
Expose this one to the new IP

Next maybe !!!!!

dn on the local machine

sudo nano /etc/resolv.conf

Change the nameserver to

nameserver 8.8.8.8
nameserver 8.8.4.4

Ctrg + x > y

Wait 5mins and try again
 
  • Love
Reactions: Admin9705

seanweldon

Blitz 3rd Class
Original poster
13
2
Hmm, the Portainer Check is still failing. Do I need a port outside of 443 and 80 NAT'd to the server? I'm able to ping portainer.my.domain from the server and it shows my public IP, so that seems right.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Trending