What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Too many requests

axlrod

Blitz 2nd Class
PG Version
8.6.4
Server Type
Remote - VPS
I believe this error is self explanatory, however, am I just screwed for a week now? It took me several attempts to get things set up, mostly because I did not have patience for my IPs to propagate from cloudflare out to the internet at large (I believe). I probably tried enabling traefik 15 or so times while trying to work through the issues.

time="2019-06-08T04:46:40+02:00" level=error msg="Unable to obtain ACME certificate for domains \"XXXX.com\" : unable to generate a certificate for the domains [XXXX.com]: acme: error: 429 :: POST :: https://acme-v02.api.letsencrypt.org/acme/new-order :: urn:ietf:params:acme:error:rateLimited :: Error creating new order :: too many certificates already issued for exact set of domains: XXXX.com: see https://letsencrypt.org/docs/rate-limits/, url: "
 

axlrod

Blitz 2nd Class
And I think more importantly how do I avoid this to begin with? I have a domain visible through cloudflare. I know I have a CNAME portainer.DOMAIN.TLD. I know I have my email and api key right. I run the enable in pgblitz and it fails. I assume a cert have been generated etc. What steps can I do to try the configuration again and not have letsencrypt block me for a week while I work out whatever issues remain?
 

Nightshade

Blitz 3rd Class
Right now, you have to wait. You have blown through the LetsEncrypt weekly rate limit for exact duplicate certificates.
You can find out more about rate limits at the link in your first post.

Next time try setting the DNS delay check to 90 seconds, as that worked with CloudFlare for me.

Also:
Try cloudflare records set to DNS only
(toggle ☁ from orange to gray)
And make sure your cloudflare page rules are setup like in the guide:

 

axlrod

Blitz 2nd Class
I have another domain I could use. I'll give it a try before I lock myself out for another week. Once I get the process down I'll come back and reconfigure for my original domain. Thanks for the hints!
 

axlrod

Blitz 2nd Class
Also, once a certificate is issued can I make sure to reuse that instead of requesting a new one again and again until it locks me out?
 

axlrod

Blitz 2nd Class
Just a quick update, thanks for the help. I did not have to click the ☁ to make it grey, orange was fine, but I did the rest of the settings and it seemed to go very well the first time. I did use a second domain I had so I might reconfigure for the domain I want to use in a week when I can try again.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Top