What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Suddenly buffering issues with plex from hetzner server

molesza

Full Member
I share my server with a couple of friends. two of them have 20mbit fiber lines and were able to stream in full HD provided the bitrate was below 20mbit obviously. Now all of a sudden neither can manage streaming over 3mbits. I'm totally stumped as to why this would be happening. Still using the same server. Does anyone have any suggestions on what I can try to troubleshoot this problem?

Thanks!
 

Admin9705

Administrator
Project Manager
The only thing I can tell you is that there are way too many factors; where they could be the main cause of the problem. Have you tried using different device to view, a second vm somewhere like your house to compare against?
 

superwoot

Full Member
I share my server with a couple of friends. two of them have 20mbit fiber lines and were able to stream in full HD provided the bitrate was below 20mbit obviously. Now all of a sudden neither can manage streaming over 3mbits. I'm totally stumped as to why this would be happening. Still using the same server. Does anyone have any suggestions on what I can try to troubleshoot this problem?

Thanks!
Have you got any feedback?
 

SkyNet

Noob
I've had similar buffer issue and found this Thread,
So i tested my transfer speed on my box

Results

PGDrive:
unionfs - 2-3 mb/s
gdrive - 75 mb/s

PlexDrive 5:
unionfs - 48 mb/s
gdrive - 7.5 - 8 mb/s

So i went back to PlexDrive 5, from PGDrive and no issue so far
 

Spoonsy1480

Legendary Member
I've had similar buffer issue and found this Thread,
So i tested my transfer speed on my box

Results

PGDrive:
unionfs - 2-3 mb/s
gdrive - 75 mb/s

PlexDrive 5:
unionfs - 48 mb/s
gdrive - 7.5 - 8 mb/s

So i went back to PlexDrive 5, from PGDrive and no issue so far
How do you check these speeds as I have the same problem
 

Chudz

Respected Member
Donor
I had the same problem the other day I thought it was my server but I found a fix. Hopefully this will help you guys. When you created your rclone remotes for gdrive. Did yous skip adding the client and sercret? if so go add them in and you wont get slow speeds. Basically your getting a "rate limit exceeded" problem.

---- Automatically Merged Double Post ----

I've had similar buffer issue and found this Thread,
So i tested my transfer speed on my box

Results

PGDrive:
unionfs - 2-3 mb/s
gdrive - 75 mb/s

PlexDrive 5:
unionfs - 48 mb/s
gdrive - 7.5 - 8 mb/s

So i went back to PlexDrive 5, from PGDrive and no issue so far
The reason this works is because when adding PlexDrive you have to add the client and secret.
 
Last edited:

Spoonsy1480

Legendary Member
I had the same problem the other day I thought it was my server but I found a fix. Hopefully this will help you guys. When you created your rclone remotes for gdrive. Did yous skip adding the client and sercret? if so go add them in and you wont get slow speeds. Basically your getting a "rate limit exceeded" problem.

---- Automatically Merged Double Post ----



The reason this works is because when adding PlexDrive you have to add the client and secret.
I have added key and secret before and still have problems
 

Chudz

Respected Member
Donor
If you load up Plex in your browser and go to a Movie or something and click the 3 dots and click Download. Check the speeds of the download speed does the speed drop now and then?
 

randyjc

Junior Member
Patron
I had the same problem the other day I thought it was my server but I found a fix. Hopefully this will help you guys. When you created your rclone remotes for gdrive. Did yous skip adding the client and sercret? if so go add them in and you wont get slow speeds. Basically your getting a "rate limit exceeded" problem.

---- Automatically Merged Double Post ----



The reason this works is because when adding PlexDrive you have to add the client and secret.
For the move service you’ll have to enter another remote. Did you used separate client ids and secret ids? For both unionfs and move?

If you load up Plex in your browser and go to a Movie or something and click the 3 dots and click Download. Check the speeds of the download speed does the speed drop now and then?
When downloading direct from browser (Utrecht NL) I’ll get a 7-9MB per second. When trying this on my shadow game pc located in France i get like 6-16 MB per second

Hetzner ex61-NVME is located in Germany FSN-1 DC12

**Update: When changing to Plexdrive5, i'm downloading with 25 to 36.. it's still scanning my library though**
 
Last edited:

astroshare

Senior Member
Donor
I was having this issue as well recently. Switched to PD5 and got steady 8MB/s downloads. It also looks like the rclone mounts are limited via the --BWLIMIT option to 9MB/s upload speed. @Admin9705 are there any plans to make this optional when deploying rclone with PD? Not all of us that use PD upload 750GB of data a day.
 

Chudz

Respected Member
Donor
I was having this issue as well recently. Switched to PD5 and got steady 8MB/s downloads. It also looks like the rclone mounts are limited via the --BWLIMIT option to 9MB/s upload speed. @Admin9705 are there any plans to make this optional when deploying rclone with PD? Not all of us that use PD upload 750GB of data a day.
It is already optional, just go into the deploy menu and change the BWLIMIT.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
4
Guests online
89
Total visitors
93
Top