What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Static IPs for docker containers?

Assists Greatly with Development Costs

kuhlimuh

Junior Member
PG Version
7.007
Server Type
Remote - Dedicated Server
Hey,

I wanted to use static IPs for plexguides containers since I can't get them to work by subdomain.domain (ie. Sonarr can only connect to Jackett with ip: port). Is there a way to achieve this?

greetings
 

timekills

Legendary Member
Staff
Donor
Of course, that's assuming they're all on the same box.
There *is* a static ip & port you can use...it's the external (addressable) IP of your server. That shouldn't change.
 

ink0gnito

Full Member
When i use the container name from nzbget in sonarr and radarr that works. But i installed also tautulli and ombi.
In ombi i can also use the containername for sonarr and radarr, but i cannot connect to plex with the containername.
Tautulli works only with the docker ip from plex.
I use debian with plexguide 7.4.13.
Anybody else with these problems?
 

hooper

Legendary Member
Staff
Donor
When i use the container name from nzbget in sonarr and radarr that works. But i installed also tautulli and ombi.
In ombi i can also use the containername for sonarr and radarr, but i cannot connect to plex with the containername.
Tautulli works only with the docker ip from plex.
I use debian with plexguide 7.4.13.
Anybody else with these problems?
I am going to assume you are running all your docker containers on a single server.

To configure Ombi, just use "plex" as your hostname and 32400 as the port number. You will also need to have your plex auth token. Put all that information in and then try the test connectivity button. Ombi is a like weird with saving settings and getting things to work, so you may have to try this a few times.

For Tautulli use "plex" for the hostname and 32400 for the port. Don't try to select a plex server from the dropdown, just type in plex. Hit Verify server, you may have to also fetch the Plex auth token. This should create a Plex server URL of http://plex:32400.

This is the configuration that I use on my PG setup, which is a single server configuration. Both of these apps have been working with this same configuration for 5+ months.
 

ink0gnito

Full Member
Yes, i have all docker container running on a single server.
I believe you, but unfortunately that does not work for me.
I can connect from ombi to radarr and sonarr with the containername without problems, but i cannot connect to plex.
Which OS did you use?
I use debian.
 

hooper

Legendary Member
Staff
Donor
I am using Ubuntu 18.04, but this config also works on another Ubuntu 16.04 host I have.

I will setup a debian system today and do a test to see if I get the same results. What Debian release are you using?
 

timekills

Legendary Member
Staff
Donor
Yes, i have all docker container running on a single server.
I believe you, but unfortunately that does not work for me.
I can connect from ombi to radarr and sonarr with the containername without problems, but i cannot connect to plex.
Which OS did you use?
I use debian.
The way explained above usually works, but occasionally I've found a small change works when the "standard" doesn't.

1) For Tatulli try "plex" for hostname, 32400 for port - but don't verify yet
2) Fetch your token
3) Check the "use SSL" box
4) Now verify server

That may force it to pull the Plex Server Identifier.
After that you can uncheck the "Use SSL" box, get the token and verify the server again. Now the Plex Server URL should say http://plex:32400

Another work around to force it is to go to your WebTools page (ip:33400) and under "Tools -> Techinfo" you can copy the MachineID and paste it into the "Plex Server Identifier" section in Tautulli to force a check. (You'll have to select "Show Advanced" in Tautulli to see that selection.)
 
Last edited:

ink0gnito

Full Member
I followed exactly these steps, but unfortunately this does not work for me.
My plex container has another ip range as the other containers.
plex container has 172.18.0... and the other containers 172.17.0....
is that so okay?
 

timekills

Legendary Member
Staff
Donor
I followed exactly these steps, but unfortunately this does not work for me.
My plex container has another ip range as the other containers.
plex container has 172.18.0... and the other containers 172.17.0....
is that so okay?
Most of the containers are in both networks. One is the "bridge" and the other the "Plex" network.
You can confirm this in Portainer....

But yeah - that's normal.
Check the edit I made to my post using the Plex Server Identifier info from the WebTools too.

Finally - sometimes it's just flaky. Try the drop-down selections while checking Remote Server and not SSL, then both, then just SSL.

But I recommend trying the WebTools way first.
 

ink0gnito

Full Member
I tried also the WebTools way, but i get an error.
"Server found but unable to connect websocket".
i tried remote with ssl and without.
 

timekills

Legendary Member
Staff
Donor
I'd recommend moving this to another thread.
In the meantime, check if you have port security enabled in Plexguide and try disabling it first, then enabling after Tautulli is working.

It shouldn't affect internal app connections though...

FWIW I have five different Tautulli/Plex connections and each are a little different in how they connect initially but eventually they did.
 

ink0gnito

Full Member
Hello i have tested plexguide on a ubuntu 18 LTS VM, and there everything works fine. You can connect from tautulli and ombi to plex with the container name.
With debian this will not work at the moment.
 

Admin9705

Administrator
Project Manager
Hello i have tested plexguide on a ubuntu 18 LTS VM, and there everything works fine. You can connect from tautulli and ombi to plex with the container name.
With debian this will not work at the moment.
Good to know. PG 7.6 2ill focus on the network aspect
 

timekills

Legendary Member
Staff
Donor
tautulli connection to the plex server is STILL flakey for me.
namely every time i open tautulli has lost the connection to the plex backend(because the container ip has chanegd after reboot for eg) and therefore my stats are not being updates correctly.
still no fix for this after all this time(unless i am doing something wrong of course).
Using the container IPs is "doing something wrong"
The best solution is to enable Port Guard and just use "plex" in the IP/hostname box
Using "plex" there will often work without the use of Port Guard, but Port Guard helps ensure there is no outside to inside DNS issues.

The alternate solution is to use the external IP or FQDN.
Never use the docker container IPs. They will change every time the container is restarted, and if multiple containers are restarted - i.e. serve reboot or the like - they don't start in any particular order so the IP they get changes.

P.S. Reading the wikis would help. This is mentioned in the wikis.
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
8
Guests online
126
Total visitors
134
Top