What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

[SOLVED - Solution in post] Sonarr/Radarr randomly stopped working

Status
Not open for further replies.

Sprort

Junior Member
Earlier today I was configuring Ombi (not doing anything to Sonarr/Radarr, not messing with Portainer, not doing anything else) I noticed that Sonarr stopped working. I refreshed the page (when working on this I am using <serverip>:<port> to access the various services) and kept seeing the "Unable to connect" error in Firefox. I tried multiple browsers, same result. The services are running in Portainer and the logs indicated that both services were scanning directories. I decided to wait a while and try to load the web UI again, still nothing worked. I restarted the containers in Portainer, rebooted the server, redeployed both Sonarr and Radarr, reinstalled Sonarr. Upon reinstalling Sonarr, the web UI worked again. I started configuring the service for indexers/downloaders and imported media successfully. I added a login form page authentication and rebooted the service when prompted to. The web UI is once again inaccessible. The log files for both indicate they are still running, but I can't access them. Has anyone else ever experienced this before?

I am using a dedicated linux server, Ubuntu 18.04.2 LTS, with a NAS.
 

Sprort

Junior Member
UPDATE
A friend just sent me a possible solution he found somewhere on the internet. After installing the Transmission container, it somehow changed the Sonarr and Radarr config.xml files. The port listing was changed to 9091 for both files. I stopped the containers and changed the port numbers back to 7878 and 8989 then started the containers. Sonarr and Radarr are now both working fine.

For anyone else who runs into this issue, the config files are located here:
/opt/appdata/radarr/config.xml
/opt/appdata/sonarr/config.xml
 
Status
Not open for further replies.

Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
11
Guests online
130
Total visitors
141
Top