What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Slow performance suddenly

3532sdt

Junior Member
PG Version
6.026
Server Type
Remote - VPS
Hello!

I have had nothing but good experiences with Rclone encryption to Google Drive, and using Plex to play the content with.

All of the sudden, most files above ~5GB (10 Mbps) is buffering every 8'ish second in Plex. Do you know why this could be? Before, it was not an issue what so ever.
I have tried to restart the server as well, just to clear the memory and what not. I have added much content recently to my Plex, but I doubt that could have any effect? The VPS that I am running my things on, has a speed of about 500+ Mbps up and down when using speedtest, and my own internet speed is about 100 Mbit, so that shouldn't be the issue either.

When using "rclone sync -v source destination" command, I am getting speeds of about 25 MB per seconds, which is far from what the files on Plex requires.

Any suggestions to what the issue might be?

EDIT:
I see (using TOP) that Rclone barely uses any CPU. It peaks at about 2% when watching something, could this be due to a faulty configuration? As said earlier, it has worked. I am not sure what the CPU usage was when it was actually working.
 
Last edited:

FeralF

Full Member
Staff
Donor
Hello!

I have had nothing but good experiences with Rclone encryption to Google Drive, and using Plex to play the content with.

All of the sudden, most files above ~5GB (10 Mbps) is buffering every 8'ish second in Plex. Do you know why this could be? Before, it was not an issue what so ever.
I have tried to restart the server as well, just to clear the memory and what not. I have added much content recently to my Plex, but I doubt that could have any effect? The VPS that I am running my things on, has a speed of about 500+ Mbps up and down when using speedtest, and my own internet speed is about 100 Mbit, so that shouldn't be the issue either.

When using "rclone sync -v source destination" command, I am getting speeds of about 25 MB per seconds, which is far from what the files on Plex requires.

Any suggestions to what the issue might be?

EDIT:
I see (using TOP) that Rclone barely uses any CPU. It peaks at about 2% when watching something, could this be due to a faulty configuration? As said earlier, it has worked. I am not sure what the CPU usage was when it was actually working.
What version of rclone are you running? Ive had similar speeds as well with access to g drive. Is this applicable?
https://forum.rclone.org/t/slow-download-from-gdrive-to-local/5733
 

3532sdt

Junior Member
What version of rclone are you running? Ive had similar speeds as well with access to g drive. Is this applicable?
https://forum.rclone.org/t/slow-download-from-gdrive-to-local/5733
1.42 which according to that link seems to be a bad version... I also max out at the said 200 Mbit when downloading or uploading to Gdrive. I just tested the downloading part and like Upload, was limited to ~23MB/s.

It could simply be your VPS provider. It's great you did some research. Unless you control all the hardware and connections inbetween, you may have to check with them also.
I will try to downgrade my Rclone version and see how it goes. If nothing changes, I will have to contact the VPS to check in with them.

EDIT:
Downgraded to 1.36, and my speed improved from the ~20MB/s to ~35MB/s, so that is always great. I have a 1 Gbit shared link, so it sometimes drops down to 400Mbit, which was the case when testing this, so I might actually have gained more than the 15MB/s increase.

The bad news: My Plex still buffers like crazy every few seconds... I will have someone else test the same media. Just to make sure that it is not just me. I have a 100 Mbit home connection, so I highly doubt it is just me, but always good to make sure.
 
Last edited:

FeralF

Full Member
Staff
Donor
1.42 which according to that link seems to be a bad version... I also max out at the said 200 Mbit when downloading or uploading to Gdrive. I just tested the downloading part and like Upload, was limited to ~23MB/s.


I will try to downgrade my Rclone version and see how it goes. If nothing changes, I will have to contact the VPS to check in with them.
Or you could try using the current version and force it to use v2 API for gdrive using the flag "--drive-v2-download-min-size=0". Not sure what would be easier. I'm on 1.42 as well but haven't resolved yet as on holiday.
 

3532sdt

Junior Member
Or you could try using the current version and force it to use v2 API for gdrive using the flag "--drive-v2-download-min-size=0". Not sure what would be easier. I'm on 1.42 as well but haven't resolved yet as on holiday.
I downgraded to 1.36 instead. See my edit of my previous post :)
 

3532sdt

Junior Member
Do a trace route to your plex server. Maybe it's the peering?
Not sure what you mean by this. I did a tracert and it timed out once, if that is what you're asking?
Anyhow, I had another person test, and for that person there was no issues. It seems to all come down to my internet connection, even though, I have 100/100.

I upgraded to Rclone V1.42 again, as V1.36 didn't support VFS which messed the UnionFS folder up for me.
 
Last edited:

clinch123

The Newb
It looks like that flag hasnt been pushed to the project yet or plexguide is still using an old version as rclone is not recognizing the flag. I cant find anything on the rclone github indicating that the fix was merged, only that it is there and waiting to be pushed. Was anyone else able to use the flag?

Aug 14 14:00:05 ovh-dedi rclone[12588]: 2018/08/14 14:00:05 Fatal error: unknown flag: --drive-v2-download-min-size
 

SirTranceALoT

Legendary Member
Staff
EDIT:
Downgraded to 1.36, and my speed improved from the ~20MB/s to ~35MB/s, so that is always great. I have a 1 Gbit shared link, so it sometimes drops down to 400Mbit, which was the case when testing this, so I might actually have gained more than the 15MB/s increase.
Could you please tell me how you did the downgrade and what your mount script looks like?
 

hylander

Junior Member
Did anyone confirm how to do the downgrade, or what changes need to be made? I'm currently running PlexGuide 6.051.
 

SirTranceALoT

Legendary Member
Staff
Downgrading to rclone 1.36 will not solve the issue. You need to rerun with your own keys.
Well it did solve it for me. Actually running 1.39 with a cached mount. I actually did not have to redo the config. Just add a second mount for the cache and change the script in the gdrive.service. I'll write a little tutorial on how I did it later.
 

timekills

Legendary Member
Staff
Donor
Well it did solve it for me. Actually running 1.39 with a cached mount. I actually did not have to redo the config. Just add a second mount for the cache and change the script in the gdrive.service. I'll write a little tutorial on how I did it later.
I'd think it would be easier just to delete the old rclone and recreate the gdrive (and tdrive if using PGBlitz) making sure you add the clientID and client secret OAuth 2.0 credentials.

Not only is that a quick and easy fix, it's also the correct way to be able to stay current with rclone. Reverting may solve some issues but will continue to cause problems as rclone is upgraded.
 

Admin9705

Administrator
Project Manager
I'd think it would be easier just to delete the old rclone and recreate the gdrive (and tdrive if using PGBlitz) making sure you add the clientID and client secret OAuth 2.0 credentials.

Not only is that a quick and easy fix, it's also the correct way to be able to stay current with rclone. Reverting may solve some issues but will continue to cause problems as rclone is upgraded.
the upgrade to rclone is fine. all you have to do is delete gdrive and tdrive and recreate with your keys and your fine :D
 

SirTranceALoT

Legendary Member
Staff
That is actually how I did it.
1. stopped the gdrive service:
service gdrive stop
2. replaced existing rclone version with 1.39
3. redid the mount in rclone according to the guide on this site.
4. created a cached mount named gcache from that gdrive mount that points to the folders plex is looking for stuff.
5. open the gdrive.service and replace everything in there with the following:
nano /etc/systemd/system/gdrive.service

[Unit]
Description=GDrive Daemon
After=multi-user.target

[Service]
Type=simple
User=0
Group=0
ExecStart=/usr/bin/rclone mount gcache: /mnt/gdrive \
--allow-non-empty \
--allow-other \
--read-only \
--cache-db-purge \
--cache-info-age=8h \
--cache-workers=10 \
--cache-db-path=/tmp/rclone/cache-backend \
--cache-chunk-size=32M \
--cache-total-chunk-size=25G \
--buffer-size 0 \
--config /root/.config/rclone/rclone.conf
ExecStop=/bin/fusermount -uz /mnt/gdrive
TimeoutStopSec=20
KillMode=process
RemainAfterExit=yes

[Install]
WantedBy=multi-user.target
6. restarted the gdrive service:
service gdrive start
now your /mnt/gdrive is pointing to the cached gdrive. It doesn't interfear with plexguide's backup. I already tested that.

but timekills's solution is actually spot-on.
 

SirTranceALoT

Legendary Member
Staff
OK. So the last options mentioned ran fine for a while but now only getting 25 MB/s again from google drive. I am using my own keys and not the default rclone ones. Now 25 MB is still more then enough but thought it was worth mentionning. Is google trying to put a lid on all of this?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
8
Guests online
87
Total visitors
95
Top