What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Remote Path Mappings - with different processing path

jeffcameron

Junior Member
Donor
Hi,
Something in a recent release seems to have caused some issues with my setup because it was working before. I am on 8.7.5 using pgblitz unecrypted with a different processing path (an external USB 3.0 HDD mounted to /media/smallext/).

Up until a recent release, my remote path mappings worked fine in Sonarr and Radarr. After looking into it, I realized that my remote path mappings were wrong according to the following link since I have a different processing path - but it never cared until a recent release apparently.

https://github.com/PGBlitz/PGBlitz.com/wiki/Remote-Path-Mappings

Once I fixed the remote path to /media/smallext/downloads/nzbget/ and /media/smallext/downloads/rutorrent/ respectively, Sonarr kicked into high gear and imported the already downloaded tv shows correctly. Radarr worked for the already downloaded files in /media/smallext/downloads/rutorrent/ but is giving me an access is denied message on several movies that had been downloaded by nzbget.

Code:
Couldn't import movie /media/smallext/downloads/nzbget/movies/The.Red.Sea.Diving.Resort.2019.iNTERNAL.MULTi.1080p.WEB.x264-CiELOS/ee3f735a880742b689e2c38755f96f03.mkv: Access to the path is denied.
Checking the permissions of that folder, it doesn't look any different than anything else (everything is set to 777 on this mounted external USB 3.0 HDD).

I did notice that there's an extra layer of sub-directories for nzbget downloads, /media/smallext/downloads/nzbget/tv and /media/smallext/downloads/nzbget/movies whereas there's just one directory for rutorrent downloads, /media/smallext/downloads/rutorrent.

1. Maybe it's some weird glitch with Radarr where it doesn't like that long of a directory path or something?

2. I'm curious if anyone knows if the Wiki is incorrect regarding the suggested Local Path setting for Remote Path Mapping when you have a different processing path. For the Local Path, it suggests that instead of /mnt/unionfs/nzbget - you should replace the /mnt with the location of you processing path, so mine would be /media/smallext/unionfs/nzbget for nzbget. When I tried setting the local path to that, it said "location does not exist" (something close to that), so I instead left it at /mnt/unionfs/nzbget. Sonarr doesn't seem to care and works fine, Radarr doesn't seem to care for rutorrent downloads.

3. Do I have something misconfigured which could be causing slower than ideal performance and/or these weird "access to the path is denied" errors in Radarr/nzbget downloads.

Thanks,
Jeff
 
Last edited:
T

TheShadow

Guest
It sounds like you do have the mappings wrong, it should look like this

Host
Remote Path​
Local Path​
nzbget
/media/smallext/downloads/nzbget/​
/mnt/unionfs/nzbget/​
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
11
Guests online
148
Total visitors
159
Top