What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Radarr - Configuration

Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
[Back To Main Wiki Homepage]

Radarr Configuration

  • Turn ON Advanced Settings in the Upper Right Corner
  • Click Save

Media Management Tab

  1. Rename Movies - Yes
  2. Analyze Video Files - No
  3. Click Save in the Upper Right Corner
Profiles Tab & Quality Tabs

  • Profiles
    • Recommend to keep the [Any] Profile
    • Make your adjusts for the [Any] Profile
  • Adjust Quality
    • Not adjusting the max may result in downloading 15GB files
    • Not adjusting the minimum size may result in 300MB 1080P files
Indexers Tab

  • Require At Least 1 Indexer
Optional To disable download of 3D movie files.

  1. Restrictions: Must not contain, 3D, 3d,SBS,sbs.
Download Client Tab
  1. Select SABNZBD and turn this one on
  2. Name: SABNZBD
  3. Host: Domain or IPv4 Address (do not use localhost)
  4. Port: 8090
  5. API Key: Visit SABNZBD @ http://your-address:8090/sabnzbd/config/general/ and retrieve the API key
  6. Username: If you created one in SABNZBD, put it here; otherwise leave blank
  7. Password: If you created one in SABNZBD, put it here; otherwise leave blank
  8. Category: Movies
  9. Recent Priority: High
  10. Older Priority: Normal or Low
General Tab:
  • Security:
  • Authentication: Forms (Login Page)
  • Username: remember it
  • Password: remember it
  • Automatic: On
  • [Click] save changes at top right
Movies Icon: [Click] at the top
  • [Click] + Add Movies
  • [Click] Bulk Import Movies (can take awhile) (only applies if you have stuff on your G-Drive)
  • [Location] If existing on disk, should be /unionfs/movies/
  • [Click] and then scroll down and click the [OK]
  • Let it load, can take awhile if you have many, if not; proceed
  • Once loaded, click the green check. After this, you're good in setting your movie location (where they currently are)
Finished
Now visit http://your-address:7878 and enjoy!

[Back To Main Wiki Homepage]
 
Last edited:

Derfla76

Full Member
[Back To Main Wiki Homepage]
Movies Icon: [Click] at the top
  • [Click] + Add Movies
  • [Click] Bulk Import Movies (can take awhile) (only applies if you have stuff on your G-Drive)
  • [Location] If existing on disk, should be /unionfs/movies/
  • [Click] and then scroll down and click the [OK]
  • Let it load, can take awhile if you have many, if not; proceed
  • Once loaded, click the green check. After this, you're good in setting your movie location (where they currently are)
Finished
Now visit http://your-address:7878 and enjoy!

[Back To Main Wiki Homepage]
But, what if it doesn't exist?

I am trying to setup PG for the 1st time using a torrent setup with Radarr and Sonarr... and to this point "/unionfs/movies/" does not exist...

Should I create or did I miss a step in the setup. "movies" does exist in /mnt/gdrive as well as in /mnt/move.
 

Admin9705

Administrator
Project Manager
But, what if it doesn't exist?

I am trying to setup PG for the 1st time using a torrent setup with Radarr and Sonarr... and to this point "/unionfs/movies/" does not exist...

Should I create or did I miss a step in the setup. "movies" does exist in /mnt/gdrive as well as in /mnt/move.
Did you try a reboot?
 

Derfla76

Full Member
Did you try a reboot?
Dang, you're quick.

Thanks for that.

Did try a reboot. Still not populated.

View Service Info for Unencrypted Unionfs is as follows:

● unionfs.service - UnionFS Daemon
Loaded: loaded (/etc/systemd/system/unionfs.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 13:00:07 CST; 5min ago
Process: 1992 ExecStart=/usr/bin/unionfs -o cow,allow_other,nonempty /mnt/move=RW:/mnt/plexdrive=RO /mnt/unionfs (code=exited, status=1/FAILURE)
Process: 1405 ExecStartPre=/bin/sleep 10 (code=exited, status=0/SUCCESS)
Main PID: 1992 (code=exited, status=1/FAILURE)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/unionfs.service

Mar 05 12:59:57 shroom-eMachines-E627 systemd[1]: Starting UnionFS Daemon...
Mar 05 13:00:07 shroom-eMachines-E627 systemd[1]: Started UnionFS Daemon.
Mar 05 13:00:07 shroom-eMachines-E627 unionfs[1992]: Failed to open /mnt/plexdrive/: Transport endpoint is not connected. Aborting!
Mar 05 13:00:07 shroom-eMachines-E627 systemd[1]: unionfs.service: Main process exited, code=exited, status=1/FAILURE

*** View the Log ***
 
Assists Greatly with Development Costs

Derfla76

Full Member
Try deleting your plexdrive keys and rerun. Looks like that’s the point of contention. Try running the latest dev update. I made some changes that may help.
Ok will give that a try... As you can see on an "emachine" :ROFLMAO::ROFLMAO::ROFLMAO: so will reply once done.
 

Admin9705

Administrator
Project Manager
Ok will give that a try... As you can see on an "emachine" :ROFLMAO::ROFLMAO::ROFLMAO: so will reply once done.
It’s always half and half. Most people make an error their first go around. Heck we had someone use UBuntu 14 another on Debian. Run the uninstaller and then dev. What version of plexdrive are you using?
 

Derfla76

Full Member
It’s always half and half. Most people make an error their first go around. Heck we had someone use UBuntu 14 another on Debian. Run the uninstaller and then dev. What version of plexdrive are you using?
Plexdrive 4 had recommended so that is what I went with.
 

Derfla76

Full Member
It’s always half and half. Most people make an error their first go around. Heck we had someone use UBuntu 14 another on Debian. Run the uninstaller and then dev. What version of plexdrive are you using?
So maybe I need to start over (???). Did an update to DEV 5.060 and removed my PD tokens. Re-ented Cliet ID and Client secret (did not create new). Getting this in Service Log now:

Log exists
● plexdrive.service - PlexDrive4 Service
Loaded: loaded (/etc/systemd/system/plexdrive.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 13:35:52 CST; 10min ago
Main PID: 1248 (code=exited, status=5)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/plexdrive.service

Mar 05 13:35:52 shroom-eMachines-E627 systemd[1]: Started PlexDrive4 Service.
Mar 05 13:35:59 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:35] INFO : Mounting path /mnt/plexdrive
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:35] INFO : Using clear-by-interval method for chunk cleaning
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:36] INFO : No last change id found, starting from beginning...
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:36] INFO : First cache build process started...
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:36] WARNING: Could not get changes
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:36] INFO : First cache build process finished!
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]: [USR/BIN/PLEXDRIVE] [2018-03-05 13:36] WARNING: Could not get object root from API
Mar 05 13:36:00 shroom-eMachines-E627 plexdrive[1248]:
Mar 05 13:36:00 shroom-eMachines-E627 systemd[1]: plexdrive.service: Main process exited, code=exited, status=5/NOTINSTALLED

*** View the Log ***
 

Derfla76

Full Member
OK, if anyone is willing...

What exactly do I need to have setup on the GDrive side.

I used the site link to sign up for the 14 day trial. It said I needed a domain so paid $12 for that. Setup a user name on GDrive and then had to create a project in order to setup the credentials.

I can only assume I did something wrong to get me in the mess I am in now :unsure:... Started out as a Radarr/Unionfs issue to now where I am getting errors with Plexdrive and rclone:

● rclone.service - RClone Daemon
Loaded: loaded (/etc/systemd/system/rclone.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 15:54:07 CST; 16s ago
Process: 8975 ExecStop=/bin/fusermount -uz /mnt/gdrive (code=exited, status=1/FAILURE)
Process: 8982 ExecStart=/bin/bash /opt/appdata/plexguide/rclone.sh (code=exited, status=1/FAILURE)
Main PID: 8982 (code=exited, status=1/FAILURE)

Mar 05 15:54:07 shroom-eMachines-E627 systemd[1]: Started RClone Daemon.
Mar 05 15:54:08 shroom-eMachines-E627 bash[8982]: 2018/03/05 15:54:08 Failed to create file system for "gdrive:": couldn't read info about Drive: googleapi: Error 403: Project 10100356009 is not found and cannot be used for API calls. If it is recently created, enable Drive API by visiting https://console.developers.google.com/apis/api/drive.googleapis.com/overview?project=10100356009 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured
Mar 05 15:54:08 shroom-eMachines-E627 systemd[1]: rclone.service: Main process exited, code=exited, status=1/FAILURE

*** View the Log ***

● plexdrive.service - PlexDrive4 Service
Loaded: loaded (/etc/systemd/system/plexdrive.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 15:50:15 CST; 1h 25min ago
Main PID: 3583 (code=exited, status=203/EXEC)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/plexdrive.service

Mar 05 15:50:15 shroom-eMachines-E627 systemd[1]: Started PlexDrive4 Service.
Mar 05 15:50:15 shroom-eMachines-E627 systemd[3583]: plexdrive.service: Failed at step EXEC spawning /usr/bin/plexdrive: No such file or directory
Mar 05 15:50:15 shroom-eMachines-E627 systemd[1]: plexdrive.service: Main process exited, code=exited, status=203/EXEC

*** View the Log ***
 

Admin9705

Administrator
Project Manager
OK, if anyone is willing...

What exactly do I need to have setup on the GDrive side.

I used the site link to sign up for the 14 day trial. It said I needed a domain so paid $12 for that. Setup a user name on GDrive and then had to create a project in order to setup the credentials.

I can only assume I did something wrong to get me in the mess I am in now :unsure:... Started out as a Radarr/Unionfs issue to now where I am getting errors with Plexdrive and rclone:

● rclone.service - RClone Daemon
Loaded: loaded (/etc/systemd/system/rclone.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 15:54:07 CST; 16s ago
Process: 8975 ExecStop=/bin/fusermount -uz /mnt/gdrive (code=exited, status=1/FAILURE)
Process: 8982 ExecStart=/bin/bash /opt/appdata/plexguide/rclone.sh (code=exited, status=1/FAILURE)
Main PID: 8982 (code=exited, status=1/FAILURE)

Mar 05 15:54:07 shroom-eMachines-E627 systemd[1]: Started RClone Daemon.
Mar 05 15:54:08 shroom-eMachines-E627 bash[8982]: 2018/03/05 15:54:08 Failed to create file system for "gdrive:": couldn't read info about Drive: googleapi: Error 403: Project 10100356009 is not found and cannot be used for API calls. If it is recently created, enable Drive API by visiting https://console.developers.google.com/apis/api/drive.googleapis.com/overview?project=10100356009 then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured
Mar 05 15:54:08 shroom-eMachines-E627 systemd[1]: rclone.service: Main process exited, code=exited, status=1/FAILURE

*** View the Log ***

● plexdrive.service - PlexDrive4 Service
Loaded: loaded (/etc/systemd/system/plexdrive.service; enabled; vendor preset: enabled)
Active: active (exited) (Result: exit-code) since Mon 2018-03-05 15:50:15 CST; 1h 25min ago
Main PID: 3583 (code=exited, status=203/EXEC)
Tasks: 0
Memory: 0B
CPU: 0
CGroup: /system.slice/plexdrive.service

Mar 05 15:50:15 shroom-eMachines-E627 systemd[1]: Started PlexDrive4 Service.
Mar 05 15:50:15 shroom-eMachines-E627 systemd[3583]: plexdrive.service: Failed at step EXEC spawning /usr/bin/plexdrive: No such file or directory
Mar 05 15:50:15 shroom-eMachines-E627 systemd[1]: plexdrive.service: Main process exited, code=exited, status=203/EXEC

*** View the Log ***
So what i'll do is to make sure your not going crazy. I have a hertzner cloud server to test. So I'll baseline and test incase :D
 

Derfla76

Full Member
So what i'll do is to make sure your not going crazy. I have a hertzner cloud server to test. So I'll baseline and test incase :D
Actually I may not need it...

I was trying to figure out the GDrive stuff myself...

And thus, late night , read: 3AM, is not great for clear thought... I enabled the API on GDrive... and who woulda thought I should enable API's. :(:(:(
 

Admin9705

Administrator
Project Manager
Actually I may not need it...

I was trying to figure out the GDrive stuff myself...

And thus, late night , read: 3AM, is not great for clear thought... I enabled the API on GDrive... and who woulda thought I should enable API's. :(:(:(
haha well i just finished the baseline test :D


To show a baseline
View attachment 364
View attachment 363
View attachment 362
View attachment 361
View attachment 360 PlexDrive Works After Reboot
View attachment 358 Installed RClone
View attachment 357 UnionFS works
 

Derfla76

Full Member
hi just setup a new root server :) but in radarr i cannot import movies from gdrive i already have downloaded ?

/mnt/gdrive/movies or /gdrive/movies radarr don't list it.
IIRC* your import should be "/unionfs/movies/".

Once you setup RClone and then Radarr and do a bulk import, Radarr should see thr movies from here.

*new myself, but a couple of setups stops and restarts lead me to this conclusion.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
13
Guests online
98
Total visitors
111
Top