Discussion Problems setting custom Rclone VFS mount settings

Robo

Blitz 3rd Class
4
0
OK, i got this fixed.

you need to pay close attention to the values in the customization menu. make sure you only have numbers between the brackets. Not a value like [64M] for example.
Thanks this fix the mount issue, now its super slow because google issues. thanks @hooper & @iDoMnCi
If your server is hosted in EU then its not going to work. Issue is with Google not PGBlitz. https://forum.rclone.org/t/all-of-a-sudden-googleapi-error-429/9977/21
 

captngimpy

Blitz Sergeant
Staff
100
23
My Plex server is 8.4.6 and was running fine until about 20-30 mins ago. So I agree with the gdrive/tdrive being the issue. I do have my server at hetzer which I assume its pulling from an eu g/tdrive server while my US feeder plugs away and I'm able to access here on my phone and computer with out an issue.
 

astroshare

Blitz Sergeant
Donor
122
35
Great, I thought it was my new network setup, since I just installed a new firewall at home. What a coincidence!!
Looks like the issue started at around 2pm today.

I rebooted the server and disabled Cloudflare to no avail. Guess we have to wait for google to fix it.

3372
 

captngimpy

Blitz Sergeant
Staff
100
23
I went to cloudflare and edited the Plex cname and clicked the orange cloud gave it a few mins and tried then server again things started working and reset it to orange still working not sure if that actually was the root but everything it working now.
 

hooper

Blitz Legioner
Original poster
Staff
Donor
297
103
Is cloudflare the issue? I just recent set up my server to run thru the CDN, but if it's not cacheing everything I don't see much of the point of doing it.
cloudflare does a few things that are beneficial

1. improves peering and reduces network hops which should improve performance with CDN enabled. especially if your server is far from you (like you are in california and your server is in germany)
2. hides your server IP address if you configure with CDN
3. speeds up access to other apps you host by caching (do not cache plex though)
 
  • Like
Reactions: captngimpy

captngimpy

Blitz Sergeant
Staff
100
23
Well one episode loaded after bypassing the cdn of cloud flare and once I re enabled it nothing else loaded I'm going to bed looks like a whole lot more is going on here that we can't truly fix completely at this time. All sounds like bad timing.
 

antigravity

Blitz 1st Class
60
6
Started getting hit with API errors over 12 hours ago. Still happening.

Both my Downloading/Processing Hetzner servers are down. Clients hosted in the US and Australia are reading off the mount just fine.
 
Last edited:

Cthe1

Blitz 3rd Class
7
14
OK, i got this fixed.

you need to pay close attention to the values in the customization menu. make sure you only have numbers between the brackets. Not a value like [64M] for example.

This is an example of a broken config:

Code:
RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [64] MB
[2] Drive-Chunk-Size           64M        [128] MB
[3] Dir-Cache-Time             2M         [1441] Minutes
[4] VFS-Read-Chunk-Size        64M        [128] MB
[5] VFS-Read-Chunk-Size-Limit  2G         [5] GB
[6] VFS-Cache-Mode             off        [writes]
[7] VFS-Cache-Max-Age          168H       [168] Hours
[8] VFS-Cache-Max-Size         100G       [100G] GB
[Z] Exit
You would need to edit the values so that there are just numbers and not characters also. so [100G] should be changed to be just [100].

This is what @Admin9705 pointed out in his reply above - i just didn't understand what was being said.
Just redeployed the mounts, think there is a problem with "Drive-Chunk-Size"

Getting this error in pgmove: Failed to create file system for "gdrive:/": drive: chunk size: 128k is less than 256k

My Settings:
Code:
RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [16] MB
[2] Drive-Chunk-Size           64M        [128] MB
[3] Dir-Cache-Time             2M         [2] Minutes
[4] VFS-Read-Chunk-Size        64M        [64] MB
[5] VFS-Read-Chunk-Size-Limit  2G         [2] GB
[6] VFS-Cache-Mode             off        [full]
[7] VFS-Cache-Max-Age          168H       [1] Hours
[8] VFS-Cache-Max-Size         100G       [20] GB
[Z] Exit
 
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
5,739
1,946
Just redeployed the mounts, think there is a problem with "Drive-Chunk-Size"

Getting this error in pgmove: Failed to create file system for "gdrive:/": drive: chunk size: 128k is less than 256k

My Settings:
Code:
RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [16] MB
[2] Drive-Chunk-Size           64M        [128] MB
[3] Dir-Cache-Time             2M         [2] Minutes
[4] VFS-Read-Chunk-Size        64M        [64] MB
[5] VFS-Read-Chunk-Size-Limit  2G         [2] GB
[6] VFS-Cache-Mode             off        [full]
[7] VFS-Cache-Max-Age          168H       [1] Hours
[8] VFS-Cache-Max-Size         100G       [20] GB
[Z] Exit
For move? Ok will check later today.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Trending