What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Plex Buffering Issue/Hetzner-Germany

Assists Greatly with Development Costs

DrAg0n141

Junior Member
Hi, am having all the Time Buffering Issues with Plex on my hetzner EX42-NVME in Germany, and Using Team-Drive for the Movies. The Buffering comes by 4K movies or 1080p random in the movie. CDN with Cloudflare is used and i have reinstalled my System with Debian 9.9 before with Ubuntu 18.04. Have someone an Idee?


## System Information

OS Name : Debian GNU/Linux 9.9 (stretch) (64 bit)
Kernel : Dedicated / 4.9.0-9-amd64
Hostname : Plex-Cloud
CPU Model : Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
CPU Cores : 8 cores @ 799.804 MHz
CPU Cache : 8192 KB
Total RAM : 64218 MiB (Free 57400 MiB)
Total SWAP : 10239 MiB (Free 10234MiB)
Total Space : 4.1PB (1% used)
Running for : 1days - 22hrs 33min 05sec


## CDN Speedtest

CacheFly : 90.11 MiB/s | 720.89 Mbps | ping 5.005ms
CDN.net : 1.19 KiB/s | 0.01 Mbps | ping 14.302ms

## North America Speedtest

Softlayer, Washington, USA : 0 B/s | N/A | ping error!
SoftLayer, San Jose, USA : 679.12 KiB/s | 5.31 Mbps | ping 156.548ms
SoftLayer, Dallas, USA : 767.08 KiB/s | 5.99 Mbps | ping error!
Vultr, New Jersey, USA : 26.22 MiB/s | 209.80 Mbps | ping 82.517ms
Vultr, Seattle, USA : 11.96 MiB/s | 95.72 Mbps | ping 154.429ms
Vultr, Dallas, USA : 14.06 MiB/s | 112.52 Mbps | ping 128.537ms
Vultr, Los Angeles, USA : 9.84 MiB/s | 78.69 Mbps | ping 159.247ms
Ramnode, New York, USA : 2.21 MiB/s | 17.70 Mbps | ping 97.523ms
Ramnode, Atlanta, USA : 1.21 MiB/s | 9.69 Mbps | ping 106.523ms
OVH, Beauharnois, Canada : 3.44 MiB/s | 27.55 Mbps | ping 94.322ms


## Europe Speedtest

Vultr, London, UK : 75.99 MiB/s | 607.93 Mbps | ping 19.961ms
LeaseWeb, Frankfurt, Germany : 102.04 MiB/s | 816.34 Mbps | ping 5.133ms
Hetzner, Germany : 100.09 MiB/s | 800.71 Mbps | ping 2.765ms
Ramnode, Alblasserdam, NL : 82.10 MiB/s | 656.81 Mbps | ping 23.563ms
Vultr, Amsterdam, NL : 93.25 MiB/s | 746.01 Mbps | ping 11.070ms
EDIS, Stockholm, Sweden : 1.87 KiB/s | 0.01 Mbps | ping 33.139ms
OVH, Roubaix, France : 89.93 MiB/s | 719.45 Mbps | ping 14.870ms
Online, France : 76.32 MiB/s | 610.59 Mbps | ping 15.087ms
Prometeus, Milan, Italy : 73.94 MiB/s | 591.53 Mbps | ping 14.384ms


## Exotic Speedtest

Sydney, Australia : 1.37 MiB/s | 10.97 Mbps | ping 316.452ms
Lagoon, New Caledonia : 642.15 KiB/s | 5.02 Mbps | ping 363.786ms
Hosteasy, Moldova : 21.72 MiB/s | 173.72 Mbps | ping 37.517ms
Prima, Argentina : 203.21 KiB/s | 1.59 Mbps | ping error!


## Asia Speedtest

SoftLayer, Singapore : 516.72 KiB/s | 4.04 Mbps | ping 181.820ms
Linode, Tokyo, Japan : 0 B/s | N/A | ping error!
Linode, Singapore : 4.81 MiB/s | 38.46 Mbps | ping 170.915ms
Vultr, Tokyo, Japan : 3.49 MiB/s | 27.92 Mbps | ping 259.531ms


## IO Test

CPU Speed:
bzip2 512MB - 160 MB/s
sha256 512MB - 251 MB/s
md5sum 512MB - 714 MB/s

Disk Speed (512MB):
I/O Speed - 2.8 GB/s
I/O Direct - 96.5 MB/s

RAM Speed (1024MB):
Avg. write - 5188.3 MB/s
Avg. read - 9830.4 MB/s

Benchmark finished in 116 seconds
results saved on /root/bench.log
 
Last edited:

Cthe1

Full Member
How is the buffering when not using the Cloudflare CDN?

Ps, Why do you use the CDN, when both you and the server is located in Germany?
 
M

MrDoob

Guest
check mal dein einstellung von plex ,

und von deinem endlcient sowie die benutze bandbreite in der zeit wo es buffert

es wird so sein das der server in der zeit evtl files hochlädt oder runterlädt


weil ich hab keinerlei probleme bei 4k

und was du auch checken kannst ist deine VFS Settings von RClone
 

DrAg0n141

Junior Member
check mal dein einstellung von plex ,

und von deinem endlcient sowie die benutze bandbreite in der zeit wo es buffert

es wird so sein das der server in der zeit evtl files hochlädt oder runterlädt


weil ich hab keinerlei probleme bei 4k

und was du auch checken kannst ist deine VFS Settings von RClone
Hab die Einstellungen genauso wie im Guide, sowohl bei Cloudlflare als auch Plex. Kann es leider nicht nachstellen, hab nur alle Freunde und Bekannte gefragt die auf dem Server schauen das es bei Ihnen immer wieder vorkommt manchmal nur einmal in einem Film manchmal auch mehrmals.
Die VFS Settings habe ich auch nicht angepasst sind genauso auf Default, habe diese auch nochmal gecheckt.
 
M

MrDoob

Guest
3598

das hier sind meine setting in PGClone

hast du im Plex Serveer auch alles auf direct stehen ??
 
M

MrDoob

Guest
netwerk card auch optimiert ??

hardware decode an ?? netzwerk karte optmiert ??

oder alles am server auf standard gelassen ??
 

DrAg0n141

Junior Member
Ja dort ist auch alles auf Direct stehen, er macht auch bei allem Direct Play. Teste gerade mit einer 4K Remux diese benötigt 135Mbps. Bisher keine Probleme, mir scheint es aber auch eher so das es Abends eher vorkommt wenn der Großteils Zuhause ist und etwas schaut.
 
M

MrDoob

Guest
pgblitz

[9] PG Tools

dann auf

[5] PG System Tweak

dann auf

[1] Network Tweaker ( Debian 9 & Ubuntu 18 only )
 

DrAg0n141

Junior Member
netwerk card auch optimiert ??

hardware decode an ?? netzwerk karte optmiert ??

oder alles am server auf standard gelassen ??
Netzwerk Optimierung nicht gemacht, Hardware Decode vom Server ist aktiv wird aber quasi nicht genutzt da jeder Direct Play nutzt.
 

DrAg0n141

Junior Member
pgblitz

[9] PG Tools

dann auf

[5] PG System Tweak

dann auf

[1] Network Tweaker ( Debian 9 & Ubuntu 18 only )
Habe ich jetzt mal drauf gespielt, hatte aber das alles schon gemacht auf der Ubuntu 18.04 Maschine mit Netzwerk Optimierung dort war der Fehler genauso.
 

DrAg0n141

Junior Member
dann teste mal deinen down speed von GDrvie über PGClone

Allocating 4G test file...
Starting upload to gdrive...
Transferred: 4G / 4 GBytes, 100%, 51.111 MBytes/s, ETA 0s
Errors: 0
Checks: 0 / 0, -
Transferred: 1 / 1, 100%
Elapsed time: 1m20.1s

Upload complete, deleting local file...
Starting download from gdrive...
Transferred: 4G / 4 GBytes, 100%, 91.227 MBytes/s, ETA 0s
Errors: 0
Checks: 0 / 0, -
Transferred: 1 / 1, 100%
Elapsed time: 44.8s

Download complete, deleting remote file...

Sieht gut aus würde ich sagen, war zwischendrin bei über 105 MBytes/s
 
M

MrDoob

Guest
dann kann es nur sein das der server evtl gerade am lasten war oder evtl. sogar das zu viele gleichzeit gucken wollten

ich würde das mal beobachten wann das ist ; und unter welchen vorraussetzungen es war
 

DrAg0n141

Junior Member
Habe nicht mal insgesamt 10 Nutzer, bei mir selbst ist es schon passiert als ich alleine auf dem Server geschaut habe.
 
M

MrDoob

Guest
Habe nicht mal insgesamt 10 Nutzer, bei mir selbst ist es schon passiert als ich alleine auf dem Server geschaut habe.
bei mir gucken manchmal 7 leute gleichzeitig und keinerlei probleme

deswegen kann ich es nicht verstehn warum es so ist


server standort ist Hellsinki - EX42
 
M

MrDoob

Guest
nur diese hier -->

Sichere Verbindungen bevorzugt

Pausierte Wiedergabe-Sitzungen abbrechen nach 10min

Begrenzung der Stream-Bitrate übers Internet : original
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
5
Guests online
125
Total visitors
130
Top