What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

PGShield not blocking access

hawkinzzz

Full Member
PG Version
8.6.5
Server Type
Remote - Dedicated Server
So, I had my set up running smoothly. Everything linking up together and working as it should. when i originally set it up I also set up PGShield and traefik. they worked perfectly! locked everybody out except me with my google log in. Recently i decided to double check it was working.... everything was open to the internet! I logged out of my google account to double check and i could still access all the apps! I asked a friend to try and access my server and all the apps and there was no security! I tried to redeploy PGShield and it said everything was ok and i made sure i set all the apps. still there was no security! I searched the forum for someone who had the same issue but the only thing i found was that someone said to update PG. I saw there was another version so i updated to the latest. its obviously a new version that is still buggy as after i redeployed PGClone it would not mount.

I have tried to revert back to 8.6.5 and redeploy everything but i am getting the same issues and now everything has stopped working.

Would anybody be able to help me get everything back up and running and get PGShield to start blocking unauthersied access again?

-----------------------------------------------------------------------------------------------

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
⛔ DEPLOY FAILED: Blitz
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

An error has occurred when deploying PGClone.
Your apps are currently stopped to prevent data loss.

Things to try: If you just finished the initial setup, you likely made a typo
or other error when configuring PGClone. Please redo the pgclone config first
before reporting an issue.

If this issue still persists:
Please share this error on Pgblitz or the forums before proceeding.

If there error says the mount is not empty, then you need to reboot your
server and redeploy PGClone to fix.

Error details:
Jul 22 13:58:25 v22019048235587431 systemd[1]: Stopping PGUnion...
Jul 22 13:58:25 v22019048235587431 systemd[1]: Stopped PGUnion.
Jul 22 13:58:37 v22019048235587431 systemd[1]: Starting gdrive Daemon...
Jul 22 13:58:37 v22019048235587431 systemd[1]: Started gdrive Daemon.
Jul 22 13:58:37 v22019048235587431 systemd[1]: gdrive.service: Main process exited, code=exited, status=1/FAILURE
Jul 22 13:58:37 v22019048235587431 fusermount[8569]: /bin/fusermount: extra arguments after the mountpoint
Jul 22 13:58:37 v22019048235587431 systemd[1]: gdrive.service: Control process exited, code=exited status=1
Jul 22 13:58:37 v22019048235587431 systemd[1]: gdrive.service: Unit entered failed state.
Jul 22 13:58:37 v22019048235587431 systemd[1]: gdrive.service: Failed with result 'exit-code'.
Jul 22 13:58:59 v22019048235587431 systemd[1]: Started PGUnion.
==> /var/plexguide/logs/pgblitz.log <==


---Starting Blitz: 2019-07-22 13:58:58---

---Begin cycle 1 - GDSA01: 2019-07-22 13:58:58---
Checking for files to upload...
2019/07/22 13:58:58 INFO : Starting bandwidth limiter at 1000MBytes/s
2019/07/22 13:58:58 INFO : Starting HTTP transaction limiter: max 10 transactions/s with burst 1
2019/07/22 13:58:58 INFO : Google drive root '': Waiting for checks to finish
2019/07/22 13:58:58 INFO : Google drive root '': Waiting for transfers to finish
2019/07/22 13:58:58 INFO :
Transferred: 0 / 0 Bytes, -, 0 Bytes/s, ETA -
Errors: 0
Checks: 0 / 0, -
Transferred: 0 / 0, -
Elapsed time: 0s

Upload has finished.
---Completed cycle 1: 2019-07-22 13:58:58---

==> /var/plexguide/logs/pg.log <==

==> /var/plexguide/logs/pgmove.log <==

==> /var/plexguide/logs/rclone-gdrive.log <==
2019/07/22 13:58:37 Fatal error: Directory is not empty: /mnt/gdrive If you want to mount it anyway use: --allow-non-empty option

==> /var/plexguide/logs/rclone-tdrive.log <==
2019/07/22 13:58:42 Fatal error: Directory is not empty: /mnt/tdrive If you want to mount it anyway use: --allow-non-empty option

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
⛔ DEPLOY FAILED: Blitz
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

-----------------------------------------------------------------------------------------------
 
Last edited:

hawkinzzz

Full Member
Just to add, I have restarted my server as the comments suggested when i got this warning and i am still having the same issue
 

hawkinzzz

Full Member
*UPDATE

I am now back up and running! I had to clear out the folders before it could unmount and remount them. not sure why but some folders got left behind.

Trying to figure out my initial issue of PGshield not protecting my apps!
 

hawkinzzz

Full Member
For some reason it is only blocking certain apps such as tautulli and ombi but not radarr, sonarr and Sabnzbd. I have tried to redeploy it a few times but its always the same
 

hawkinzzz

Full Member
I don't think that is a stable release yet. That seemed to be what caused the issue in the first place. I have reverted back to 8.6.10 and managed to get my systems working but PGShield is still not working. It says it has deployed with no errors but when trying to access my apps, I can do without being logged into my Google account (this has been verified by other people who have never logged into my account on their device).
 

gadgethome

Senior Member
Moderator
Donor
I'm on 8.7.4. just upgraded yesterday. I opened a private browser session, open both radarr and sonarr and both are prompting me to sign into google.
 

hawkinzzz

Full Member
just now when checking with private browser i got "Error: redirect_uri_mismatch ". thats the same with all the apps that are supposed to be blocked. the apps that are not supposed to be blocked open fine. when accessing the apps that are supposed to be blocked on my normal browser they seam to go through just fine without logging into my google account. I will upgrade to the newest version and do some more testing when i get time
 

hawkinzzz

Full Member
Just looking back over the Wiki and i have created a new client ID and secret with the correct authorized domains and correct Authorized redirect URI. redeploying PGShield now to see how it goes. I was using the client ID and Secret use d for GDrive so that could have been the issue all along! and also not correct OAuth 2.0 client type with the correct Authorized URL's
 
I had a similar issue as you described. I had all working I had previously checked from a remote VM and everything was blocked as it asked for a google account. I randomly check this because I am still not 100% confident it always work. One morning maybe 2 weeks ago. I tried it and it was wide open. I tried redeploying PGshiled and said all was blocked so I allowed everything and then blocked again ans started working. I now check every day.

I would much rather have it completly fail if OAuth is failing rather than letting it wide open. OAuth not working = Page simply won't open, not grant access.

I still don't know why it happened, I guess it was a bug of some sort and has not happened again.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Top NZB NewsGroups!

Members - Up To a 58% Discount!

Development Donations

 

Online statistics

Members online
8
Guests online
114
Total visitors
122
Top