What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion PG9 Feedback Forum

antigravity

Respected Member
Firstly, thank you for your work. PGBlitz is amazing and the amount of time you've spent on this project must be immense.

Quick question - why change the file locations?This will break any existing setups (ie. Sonarr, Radarr, Plex, Sabnzbd all reference the old locations)

For example - to change Plex from /mnt/unionfs/tv to /pg/unity/tv will require a complete library rebuild in Plex, and a massive database update in Sonarr and any other software that reference /mnt/unionfs/tv.

Why not leave the directories the same? Does it matter what the actual directories are called?
 

Admin9705

Administrator
Project Manager
This has been meant to be done for quite awhile in regards to everything. Everything is located under /pg and stops the permissions issues most encounter. The name team drive has gone away and is shared drives and using unionfs was confusing overtime because different items were changed. Also /opt/appdata is now /pg/data, /var/plexguide is now /pg/var and more. Basically, this is to standardize pg for the long run. There are more reasons, but it’s the overall idea. This is what I meant by baggage in the change log right up.
 
Last edited:

fa99x24

Full Member
Thanks for PG9 Beta!

When trying to install on fresh Ubuntu Server 18.04 I get the following error:
Code:
Reading package lists... Done                                                                                                                                                                                                                 
Building dependency tree                                                                                                                                                                                                                       
Reading state information... Done                                                                                                                                                                                                             
curl is already the newest version (7.58.0-2ubuntu3.7).                                                                                                                                                                                       
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.                                                                                                                                                                                 
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                   
🌎  NOTICE: PGBlitz Version 9 - Installer                                                                                                                                                                                                     
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                   
By installing, you agreeing to the terms and conditions of the GNUv3 License!                                                                                                                                                                 
Thanks To The: Linux Noobs, Sponsors, Supporters, Community, & You!                                                                                                                                                                           
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                   
Please Standby!                                                                                                                                                                                                                               
sh: 38: git: not found                                                                                                                                                                                                                         
bash: /pg/stage/pyansible.sh: No such file or directory
After installing git and starting the installation again the following error appears:
Code:
Please Standby!
Cloning into '/pg/stage'...
remote: Enumerating objects: 126, done.
remote: Counting objects: 100% (126/126), done.
remote: Compressing objects: 100% (94/94), done.
remote: Total 962 (delta 74), reused 77 (delta 32), pack-reused 836
Receiving objects: 100% (962/962), 128.08 KiB | 693.00 KiB/s, done.
Resolving deltas: 100% (650/650), done.
sh: 49: ansible-playbook: not found
/pg/stage/pgcloner/solo/update.sh: line 16: ansible-playbook: command not found
 

Admin9705

Administrator
Project Manager
Good to know. I have not seen that but helps. If trying again, install git. Without it all the other errors will continue. I’ll work on that piece.
Not on our end, but apt-install git - if this doesn’t work, try on LTS. You may have a front end where you have nothing established, but can look into it.
 

PlexFan

Full Member
Staff
Thanks for PG9 Beta!

When trying to install on fresh Ubuntu Server 18.04 I get the following error:
Code:
Reading package lists... Done                                                                                                                                                                                                               
Building dependency tree                                                                                                                                                                                                                     
Reading state information... Done                                                                                                                                                                                                           
curl is already the newest version (7.58.0-2ubuntu3.7).                                                                                                                                                                                     
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.                                                                                                                                                                               
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                 
🌎  NOTICE: PGBlitz Version 9 - Installer                                                                                                                                                                                                   
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                 
By installing, you agreeing to the terms and conditions of the GNUv3 License!                                                                                                                                                               
Thanks To The: Linux Noobs, Sponsors, Supporters, Community, & You!                                                                                                                                                                         
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━                                                                                                                                                                 
Please Standby!                                                                                                                                                                                                                             
sh: 38: git: not found                                                                                                                                                                                                                       
bash: /pg/stage/pyansible.sh: No such file or directory
After installing git and starting the installation again the following error appears:
Code:
Please Standby!
Cloning into '/pg/stage'...
remote: Enumerating objects: 126, done.
remote: Counting objects: 100% (126/126), done.
remote: Compressing objects: 100% (94/94), done.
remote: Total 962 (delta 74), reused 77 (delta 32), pack-reused 836
Receiving objects: 100% (962/962), 128.08 KiB | 693.00 KiB/s, done.
Resolving deltas: 100% (650/650), done.
sh: 49: ansible-playbook: not found
/pg/stage/pgcloner/solo/update.sh: line 16: ansible-playbook: command not found
I installed on an LTS copy and works. Server has barebone nothing. They will have to add some items in the pre-script for Server.
 

Admin9705

Administrator
Project Manager
Firstly, thank you for your work. PGBlitz is amazing and the amount of time you've spent on this project must be immense.

Quick question - why change the file locations?This will break any existing setups (ie. Sonarr, Radarr, Plex, Sabnzbd all reference the old locations)

For example - to change Plex from /mnt/unionfs/tv to /pg/unity/tv will require a complete library rebuild in Plex, and a massive database update in Sonarr and any other software that reference /mnt/unionfs/tv.

Why not leave the directories the same? Does it matter what the actual directories are called?
Note for Sonarr and Radarr and Lidarr, use the mass edit and it will change the paths to all the files easily. It’s really plex that would require a rescan.
 

fa99x24

Full Member
Good to know. I have not seen that but helps. If trying again, install git. Without it all the other errors will continue. I’ll work on that piece.
After I installed git and ansible everything worked as expected, was just kinda surprised the install script doesn't already check for needed apps :)
 

hooper

Legendary Member
Staff
Donor
will the release of PG9 be an upgrade or will it require a new install like this beta?
 

Admin9705

Administrator
Project Manager
After I installed git and ansible everything worked as expected, was just kinda surprised the install script doesn't already check for needed apps :)
ya it's the same earlier install script for PG8. I'll tweak it. Thanks! Let me know how everything else goes.
 
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
will the release of PG9 be an upgrade or will it require a new install like this beta?
you can start using this now. the upgrades patch on top of it. If using plex, usenet, sonar/radar; works great but not all the tools work. Traefik works.
 

Armin

Senior Member
Staff
Ubuntu 18.04.3 LTS (GNU/Linux 4.15.0-1040-gcp x86_64)
Please Standby!
sh: 38: git: not found
sh: 49: ansible-playbook: not found
bash: /pg/stage/pgcloner/solo/update.sh: No such file or directory
cp: cannot stat '/pg/stage/alias/plexguide': No such file or directory
cp: cannot stat '/pg/stage/alias/pg': No such file or directory
cp: cannot stat '/pg/stage/alias/pgblitz': No such file or directory
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
⌛ Verifiying Started Commands Installed via @ /bin
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
⛔ WARNING! The PGBlitz Installer Failed ~ http://pgblitz.wiki
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
Please Reinstall PGBlitz by running the Command Again! This step is to
ensure that everything is working prior to the install!
Ensure that you utilizing the correct versions of linux as described on
the installation page!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
EXITING!!!
so had to fix with these
sudo apt install git
  • sudo apt update
  • sudo apt install software-properties-common
  • sudo apt-add-repository ppa:ansible/ansible
  • sudo apt update
  • sudo apt install ansible
 
Last edited:

antigravity

Respected Member
Note for Sonarr and Radarr and Lidarr, use the mass edit and it will change the paths to all the files easily. It’s really plex that would require a rescan.
Basically any/all directory references in every app will need to be updated. RuTorrent, Sabnzbd, Jackett, NZBHydra, Emby, Plex... Thats a massive change to any existing setup that creates many potential failure points and/or a lot of work for the user to upgrade.

Not to mention any custom mount points based on the existing directory structure.

If the user has thousands of Movies and TV Shows, this could be days of downtime?
 

Admin9705

Administrator
Project Manager
Basically any/all directory references in every app will need to be updated. RuTorrent, Sabnzbd, Jackett, NZBHydra, Emby, Plex... Thats a massive change to any existing setup that creates many potential failure points and/or a lot of work for the user to upgrade.

Not to mention any custom mount points based on the existing directory structure.

If the user has thousands of Movies and TV Shows, this could be days of downtime?
Understand but the user can stay on PG8. Even I have to converge but really the downtime will be plex and emby. There are some users in pg 5,6 and 7 and 8. I wish plex made it less problematic when changing mounts as radarr and sonarr do. My main server will stay on PG8 until I have to really switch over. I have two servers so when the secondary is up and running, I’ll redo the main (until a reason to)
 
Assists Greatly with Development Costs

fa99x24

Full Member
pgupdate doesn't seem to work yet:

/bin/pgupdate: line 11: sudocheck: command not found
/bin/pgupdate: line 12: missingpull: command not found
/bin/pgupdate: line 13: exitcheck: command not found
 

bubbadk

Legendary Member
Staff
i'm glad that all my movies and series are setup in genres..so it won't take my plex so long to update to the new directories :)
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Thread starter Similar threads Forum Replies Date
Admin9705 PG Script Questions & Bugs 1
Escondido Blitz Apps 1
Whatdafuq Ideas & Suggestions 2

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
12
Guests online
101
Total visitors
113
Top