What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

PG Shield - Not authorized

Assists Greatly with Development Costs

zerith

Junior Member
Donor
PG Version
v9.0.1
Server Type
Remote - Dedicated Server
Hi,

I've started running into problem when accessing applications from my laptop in Chrome. I instantly get "Not authorized" without a redirect to google. Clearing cache did not fix the issue. When I access via incognito the functionality works as expected, and any other pc also works as expected.

Any ideas as to what could cause this?
 

pb1051

Respected Member
I have been having this issue. Admin pushed an update, but that did not work for me either.

Edit: I'm on 8.7.5
 
Last edited:

Cthe1

Full Member
Hi,

I've started running into problem when accessing applications from my laptop in Chrome. I instantly get "Not authorized" without a redirect to google. Clearing cache did not fix the issue. When I access via incognito the functionality works as expected, and any other pc also works as expected.

Any ideas as to what could cause this?
You need to delete all the cookies associated with your domain, and then logout of google.
It's not enough to just delete the cache.


I have been having this issue. Admin pushed an update, but that did not work for me either.
If it works in incognito. The update worked. If it's still not working in incognito, try deleting the oauth appdata folder and container.

https://pgblitz.com/threads/problems-with-pgshield.5267/#post-33500


 

pb1051

Respected Member
You need to delete all the cookies associated with your domain, and then logout of google.
It's not enough to just delete the cache.




If it works in incognito. The update worked. If it's still not working in incognito, try deleting the oauth appdata folder and container.

https://pgblitz.com/threads/problems-with-pgshield.5267/#post-33500
So I did this multiple times and the OAuth is still failing. I guess there is another bug in the script somewhere affecting my implementation.
 

zerith

Junior Member
Donor
Sorry by deleting cache I meant i deleted everything except for the browsing history which removed all login session data, cookies, saved information etc. Even this did not fix the issue.
 

mackattack57

Full Member
Sorry by deleting cache I meant i deleted everything except for the browsing history which removed all login session data, cookies, saved information etc. Even this did not fix the issue.

Did you change the time frame on the delete to all-time? I just fixed this issue in 8.7.5 with that. I deleted at first and didn't get results. When I went to do it again, I noticed the time frame option. I changed it and got the positive result.
 

zerith

Junior Member
Donor
yes, I deleted with"All Time" selected. Hated to do it though as all configs was lost, but thought its my easiest option. Did not work however.
 

Cthe1

Full Member
Weird, what about trying a proper browser? :p
It must be something Chrome is not deleting properly.
Tried logging in to Gmail to authorizing your user and then visiting the page?
 

Xployt

Senior Member
Moderator
Try a different browser or another instance of chrome on a different device.

Generally new OAuth keys, redeploy and a cache clear out (all time and all site settings) will fix this.

If that's still causing dramas also redeploy Traefik.
 

Xployt

Senior Member
Moderator
Hope you manage to get it sorted, when you can update us with how you're getting on, the community is great and everyone is always willing to help.
 

pb1051

Respected Member
I still am running without OAuth as it is not working for my case any longer. Using Opera (Chrome based) browser. It would be nice to have that safety blanket working once again.
 

zerith

Junior Member
Donor
So I've done a complete new install to a VPS. Still can't access the websites using chrome in default mode from my laptop as it shows the authentication error. Still able to use it in incognito mode as well as other browsers. Clearing cache and saved setting in browser did not resolve this. It just does not do the redirect. I've tried forcing the normal redirect and clicking on the correct account to sign in, this however did not resolve it either. Chrome works from my desktop in all modes as expected.
 

Cthe1

Full Member
So I've done a complete new install to a VPS. Still can't access the websites using chrome in default mode from my laptop as it shows the authentication error. Still able to use it in incognito mode as well as other browsers. Clearing cache and saved setting in browser did not resolve this. It just does not do the redirect. I've tried forcing the normal redirect and clicking on the correct account to sign in, this however did not resolve it either. Chrome works from my desktop in all modes as expected.
If you are using the same domain, you will get the same problem.
The problem is on your computer, not VPS.

Logout of Google, go to you page, open dev tools (F12) and press and hold your reload page icon, chose "Empty Cache and Hard Reload". Close your browser and try again.

If that doesn't work, open chrome://settings/content/cookies in your address bar, press See all cookies and site data.
Delete all data accoatiated with your domain and google.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
12
Guests online
100
Total visitors
112
Top