What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion NzbHydra and NzbGet docker containers broken

Status
Not open for further replies.

roxxas144

Noob
Donor
PG Version
5.093
Server Type
Remote - Dedicated Server
Looks like watchtower pulled down a new update of the nzbhydra and nzbget container https://hub.docker.com/r/hotio/suitarr/ and now I am getting a repeating of the following in my docker logs:

s6-applyuidgid: fatal: unable to exec /app/nzbhydra2: No such file or directory

s6-applyuidgid: fatal: unable to exec /app/nzbget: No such file or directory

I tried to do some digging but I couldn't figure out what is happening.

I tried redeploying both containers through plex guide and no dice.
 
Last edited by a moderator:

Stupifier

Senior Member
Staff
Donor
Looks like watchtower pulled down a new update of the nzbhydra and nzbget container https://hub.docker.com/r/hotio/suitarr/ and now I am getting a repeating of the following in my docker logs:

s6-applyuidgid: fatal: unable to exec /app/nzbhydra2: No such file or directory

s6-applyuidgid: fatal: unable to exec /app/nzbget: No such file or directory

I tried to do some digging but I couldn't figure out what is happening.

I tried redeploying both containers through plex guide and no dice.
I'm on 5.093 and both Hydra and NZBGet and working fine.....dunno
 

Admin9705

Administrator
Project Manager
I ran it also and the are running fine. you might have to check with their community as they are the ones who build it.

---- Automatically Merged Double Post ----

Using Version 5.094 and comes up

1529244334093.png
 
Last edited:

Stupifier

Senior Member
Staff
Donor
Well! Now Immediately following a WatchTower triggered update of NZBGet just about 15 minutes ago.....NZBGet no longer works.

Just says "Error: 503 Service Unavailable" when I navigate on Browser to NZBGet......Also interesting, I have to enter the default login credentials to get in to see that message. My custom login creds don't work.

For now, I just restored NZBGet from a backup I had and it works. Disabled WatchTower to prevent it from updating until fixed.

Update: Plexguide dev (Admin9705) is fixing the issue. hotio/Suitarr changed things around and didn't warn anyone.....that is what is causing the issue.

Code:
Successfully installed into /app,
Web-interface is on http://localhost:6789 (login:nzbget, password:tegbzn6789),
For support please visit http://nzbget.net/forum,
[cont-init.d] 10-install-app: exited 0.,
[cont-init.d] 11-setup-config: executing... ,
[cont-init.d] 11-setup-config: exited 0.,
[cont-init.d] 20-mount-rclone: executing... ,
[cont-init.d] 20-mount-rclone: exited 0.,
[cont-init.d] 21-mount-rar2fs: executing... ,
[cont-init.d] 21-mount-rar2fs: exited 0.,
[cont-init.d] done.,
[services.d] starting services,
[services.d] done.,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
nzbget.conf(0): Invalid value for option "TempDir" (/root/downloads/tmp): could not read information for directory /root/downloads/tmp: errno 13, ,
nzbget.conf(0): Invalid value for option "QueueDir" (/root/downloads/queue): could not read information for directory /root/downloads/queue: errno 13, ,
nzbget.conf(0): Invalid value for option "NzbDir" (/root/downloads/nzb): could not read information for directory /root/downloads/nzb: errno 13, ,
[ERROR] nzbget.conf(0): Invalid value for option "TempDir" (/root/downloads/tmp): could not read information for directory /root/downloads/tmp: errno 13, ,
[ERROR] nzbget.conf(0): Invalid value for option "QueueDir" (/root/downloads/queue): could not read information for directory /root/downloads/queue: errno 13, ,
[ERROR] nzbget.conf(0): Invalid value for option "NzbDir" (/root/downloads/nzb): could not read information for directory /root/downloads/nzb: errno 13, ,
[INFO] Pausing all activities due to errors in configuration,
[ERROR] Could not read configuration templates,
[INFO] nzbget 20.0 server-mode,
/root/downloads/nzbget.log: Permission denied,
[WARNING] Web-Server: 503 Service Unavailable, Resource: /,
/root/downloads/nzbget.log: Permission denied,
[WARNING] Web-Server: 503 Service Unavailable, Resource: /favicon.ico,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
[WARNING] Web-Server: 503 Service Unavailable, Resource: /,
[WARNING] Web-Server: 503 Service Unavailable, Resource: /favicon.ico,
/root/downloads/nzbget.log: Permission denied,
/root/downloads/nzbget.log: Permission denied,
 
Last edited:

Stupifier

Senior Member
Staff
Donor
Tested Update....You fixed it. Thanks

Also FYI, After testing, I just jumped ship on hotio/suitarr containers......I always preferred LinuxServer
 
Status
Not open for further replies.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
5
Guests online
86
Total visitors
91
Top