What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

nzbget-mp4

FullCycle

Blitz 2nd Class
If you 'cat' the cont-init.d/30-config file, the last entry in the file should be:

exec /config/installer/installer.sh
 

captngimpy

Blitz Sergeant
Staff
Can you explain the putting tv,movies in the bypass and not just in the catagories for sonarr and raddar

Edit: I can confirm the 30-config is as followed
Code:
#!/usr/bin/with-contenv bash

# delete lock file if found
[[ -f /downloads/nzbget.lock ]] && \
        rm /downloads/nzbget.lock

# check if config file exists in /config
[[ ! -f /config/nzbget.conf ]] && \
        cp /defaults/nzbget.conf /config/nzbget.conf

# permissions
chown 1000:1000 \
        /downloads
chown 1000:1000 -R \
        /app/nzbget \
        /config
chmod u+rw \
        /config/nzbget.conf

chmod 777 -R \
        /config
chmod 777 -R \
        /app/nzbget
chmod 777 -R \
        /downloads

exec /config/installer/installer.sh
 
Last edited:

FullCycle

Blitz 2nd Class
This deployment overwrites the default nzbget pp script with a slightly modified one, taken from an issue thread on GitHub. (ought to merge it in really...)

What it allows for, is multiple catagories to be added as bypass catagories, rather than just one. When a catagory is set to bypass, they will still be processed, but then passed back to nzbget and marked as complete. Rather than being passed on to sonarr or radarr directly.

There are 2x benefits here. Firstly, this can be preset, so less user configuration needdd. Secondly, and now more importantly, the sonarr/radarr download handler with work with remote path sharing.
 

Klavikus

Blitz 2nd Class
Just installed this - used the method of installing nzbget first then the mp4 version afterwards.

However when all set up I am getting a PP failure when it passes to the MP4 script

MP4/Automator/NZBGetPostProcess.py for filename failed (terminated with unknown status)
 
Assists Greatly with Development Costs

kkalfun

Blitz 2nd Class
Bump.

I installed the base image and NZBGet loaded just fine. I then installed this on top afterwards, and now NZBGet won't even load. I checked portainer and it's running fine.
 

captngimpy

Blitz Sergeant
Staff
The first time you run this it will take some time because it is building the packages. Check the logs on portainer.
 

ch1p2014

Blitz 1st Class
Sponsor
@Klavikus did yiu manage to sort the

MP4/Automator/NZBGetPostProcess.py for filename failed (terminated with unknown status) ?

ive tried this again and my errors are :-


Executing post-process-script MP4_Automator/NZBGetPostProcess.py for Knight.Rider.S02E03.REMASTERED.BDRip.x264-PHASE

ERRORSun Jun 30 2019 18:57:47Post-process-script MP4_Automator/NZBGetPostProcess.py for Knight.Rider.S02E03.REMASTERED.BDRip.x264-PHASE failed (terminated with unknown status)
INFOSun Jun 30 2019 18:57:47NZBGetPostProcess: SyntaxError: invalid syntax
INFOSun Jun 30 2019 18:57:47NZBGetPostProcess: ^
INFOSun Jun 30 2019 18:57:47NZBGetPostProcess: MP4_FOLDER=~/sickbeard_mp4_automator/
INFOSun Jun 30 2019 18:57:47NZBGetPostProcess: File "/config/scripts/MP4_Automator/NZBGetPostProcess.py", line 17

this is how i have my NZBGetPostProcess.py setup

##############################################################################
### OPTIONS ###

# Change to full path to MP4 Automator folder. No quotes and a trailing /
MP4_FOLDER=~/sickbeard_mp4_automator/

# Convert file before passing to destination (True, False)
#SHOULDCONVERT=False

# Category for Couchpotato
#CP_CAT=Couchpotato

# Category for Sonarr
SONARR_CAT=tv

# Category for Radarr
#RADARR_CAT=Radarr

# Category for Sickbeard
#SICKBEARD_CAT=Sickbeard

# Category for Sickrage
#SICKRAGE_CAT=Sickrage

# Category list (comma seperated) for bypassing any further processing but still converting
BYPASS_CAT=

# Custom output_directory setting
#OUTPUT_DIR=


Any help appreciated
 

ch1p2014

Blitz 1st Class
Sponsor
ive tried on 2 different servers and exactly the same results.
so unfortunately for me i cant do ANY automatic mp4 converting :(
tried so far :-
1 : nzbget-mp4
2 : manic

Is there anything else ?
 

ch1p2014

Blitz 1st Class
Sponsor
has anyone got nzbget-mp4 running with minimum setup ? my setup is default with /mnt/unionfs/ paths.

really desperate if anyone could please shed any light.
 

captngimpy

Blitz Sergeant
Staff
You shouldn't be editing the NZBGetPostProcess.py you should be changing those settings inside NZBGET. Editing the python file directly can cause errors. As it has been established unless you are using the special lib you really don't need this version. You can install just nzbget and then access the docker directly and install sickbeard normally by following the directions on the offcial github. I will say that our built in one here is super broken and really not useable unless you know what you are doing.

I believe the correct path should be /config/scripts/MP4_Automator/ also and change should convert to TRUE
 
Last edited:

ch1p2014

Blitz 1st Class
Sponsor
lol super broken ... your telling me tbh id have thought this would be one off the key element programmes as we know plex transcoding kills your server.

thank you for the reply i will give that a go
 

captngimpy

Blitz Sergeant
Staff
Well you can have sonarr and radarr encode to mp4. Honestly a lot of my users transcode and my server doesn't really have a problem. But I still have nzbget encoding to mp4 then sonar and radarr picking it up and running it back thru to complete the moving of the moov atom as I have read this helps with playback
 

ch1p2014

Blitz 1st Class
Sponsor
i would really love to get this going, i have removed nzbget totally and re installed and reinstalled the nzbget-mp4 over the top.

i have added the path /config/scripts/MP4_Automator/ and changed to True

i have these following errors

ERRORWed Jul 03 2019 23:10:55Post-process-script MP4_Automator/NZBGetPostProcess.py for 24.S08E23.HDTV.XviD-LOL failed (terminated with unknown status)
ERRORWed Jul 03 2019 23:10:55NZBGetPostProcess: None
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: ImportError: No module named babelfish
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: from babelfish import Language
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: File "/config/scripts/MP4_Automator/readSettings.py", line 11, in <module>
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: from readSettings import ReadSettings
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: File "/config/scripts/MP4_Automator/NZBGetPostProcess.py", line 74, in <module>
INFOWed Jul 03 2019 23:10:55NZBGetPostProcess: Traceback (most recent call last):
ERRORWed Jul 03 2019 23:10:55NZBGetPostProcess: Wrong path to sickbeard_mp4_automator: /scripts/MP4_Automator/
Showing records 1-10 from 650
 

ch1p2014

Blitz 1st Class
Sponsor
[INFO] Executing post-process-script MP4_Automator/NZBGetPostProcess.py for 2.Broke.Girls.S05E22.720p.HDTV.X264-DIMENSION

[ERROR] NZBGetPostProcess: Wrong path to sickbeard_mp4_automator: /config/scripts/sickbeard_mp4_automator/

[INFO] NZBGetPostProcess: Traceback (most recent call last):

[INFO] NZBGetPostProcess: File "/config/scripts/MP4_Automator/NZBGetPostProcess.py", line 74, in <module>

[INFO] NZBGetPostProcess: from readSettings import ReadSettings

[INFO] NZBGetPostProcess: File "/config/scripts/MP4_Automator/readSettings.py", line 11, in <module>

[INFO] NZBGetPostProcess: from babelfish import Language

[INFO] NZBGetPostProcess: ImportError: No module named babelfish

[ERROR] NZBGetPostProcess: None

[ERROR] Post-process-script MP4_Automator/NZBGetPostProcess.py for 2.Broke.Girls.S05E22.720p.HDTV.X264-DIMENSION failed (terminated with unknown status)



so frustrating !!
 

captngimpy

Blitz Sergeant
Staff
well the /config/scripts/MP4_Automator/ you can see is the correct path it was reading the file you are missing a dependency. Did you let it complete the build process after you the docker container was created. That process and take 10mins or more on first run.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Trending

Top