What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

New GCE having problems with PG Shield

Signup20

Full Member
PG Version
8.7.5
Server Type
Google - GCE
All apps worked prior to PG Shield being enabled. In my primary Chrome browser, I get a "not authorized" message for protected apps. The strange thing is, if I open an Incognito window and go to the same app, I am prompted for my credentials and then am able to access the app. Same thing if I open in Safari. It's just chrome that gives me the error (both on my desktop and mobile).

I have been pulling my hair out for 2 days now trying to figure it out (I have destroyed and rebuilt multiple GCE servers...).

Any help would be greatly appreciated.


Edit: I should add that I provisioned a new GCE as my credits were running low. Everything was working perfectly previously and PG Vault ran flawlessly to restore my backups. I then redeployed my apps and ran Traefik and Port Guard successfully. I verified all apps working before trying to apply PG Shield.
 
Last edited:

Signup20

Full Member
All apps worked prior to PG Shield being enabled. In my primary Chrome browser, I get a "not authorized" message for protected apps. The strange thing is, if I open an Incognito window and go to the same app, I am prompted for my credentials and then am able to access the app. Same thing if I open in Safari. It's just chrome that gives me the error (both on my desktop and mobile).

I have been pulling my hair out for 2 days now trying to figure it out (I have destroyed and rebuilt multiple GCE servers...).

Any help would be greatly appreciated.


Edit: I should add that I provisioned a new GCE as my credits were running low. Everything was working perfectly previously and PG Vault ran flawlessly to restore my backups. I then redeployed my apps and ran Traefik and Port Guard successfully. I verified all apps working before trying to apply PG Shield.
Solved! Just came across https://www.petefreitag.com/item/857.cfm which talked about session variable as a potential issue. I had cleared my browser history/data previously but that didn't work. This time I used Inspect tool in Chrome, went to the Application tab, Clear Storage, and I clicked the Clear Site Data button. That did the trick!

Sharing in case anyone else (including my future self) may run into a similar issue.
 

Admin9705

Administrator
Project Manager
Solved! Just came across https://www.petefreitag.com/item/857.cfm which talked about session variable as a potential issue. I had cleared my browser history/data previously but that didn't work. This time I used Inspect tool in Chrome, went to the Application tab, Clear Storage, and I clicked the Clear Site Data button. That did the trick!

Sharing in case anyone else (including my future self) may run into a similar issue.
Ah ya. I forgot about that. I'll update the wiki with that info on the PG9 rewrite.
 

Signup20

Full Member
I just realized that my phone's Chrome browser is still experiencing this problem. Any suggestions to fix?
Just answered my own question again.

Go into Settings, Site Settings, Storage and the Clear Data for the site required. In my case, I did this for only 1 of the apps and after signing into the site with my google ID, all sites started working again.

Hope this helps.
 

Admin9705

Administrator
Project Manager
Solved! Just came across https://www.petefreitag.com/item/857.cfm which talked about session variable as a potential issue. I had cleared my browser history/data previously but that didn't work. This time I used Inspect tool in Chrome, went to the Application tab, Clear Storage, and I clicked the Clear Site Data button. That did the trick!

Sharing in case anyone else (including my future self) may run into a similar issue.
I checked the link and that’s a nice blog writeup
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
5
Guests online
116
Total visitors
121
Top