What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Mylar and Ubooquity Configuration

Assists Greatly with Development Costs

pentaganos

Full Member
Here we are going to setup Mylar and Ubooquity to streamline the reading of Ebooks and Comics.

MYLAR Access
General Configuration
  • You want to click the "Gears" Icon at the top right of the page.
  • Click the "Web Interface" tab.
    • Add a http username and password(testing https).
    • Paste your Comic Vine API Key into the API Section.
    • Set your "Comic Location Path" to /unionfs/comics/
  • Click the "Download Settings" tab.
    • Enter your usenet or Torrents details.
  • Click the "Search Providers" tab.
    • Add your search provider details, if your provider doesn't appear on the left(not many do) you can tick "Use Newznab" and add your details there, don't forget to tick enabled.
  • Click the "Quality & Post Processing" tab(these are my settings, play around with what works for you).
    • Quality: Whichever - Just get it.
    • No minimum or maximum file size.
    • Duplicate Handling Retain based on "Filesize"
    • Duplicate dump folder un-ticked.
    • Failed Download Handling un-ticked(Should probably be ticked).
    • Post-Processing enabled.
    • "When Post-Processing" Move, If using torrents this should be copy or hardlink.
  • MAKE SURE TO HIT SAVE AFTER EACH TAB.
Ubooquity Access
* Domain is work in progress.
 

barryclamsworth

Legendary Member
Donor
http://<domain>:2203/ubooquity/admin and http://<domain>:2202/ubooquity both work for me.

For anyone trying to access the uboouity admin panel there is an error with the current docker version and setting the admin password on the first run fails to complete. You can get around this by installing an older version and creating the file needed with that. I created the file on my home server and copied the webadmin.cred to the config folder on my plexguide server.

I am fairly sure I used v 71 to create the cred file.

Code:
  ubooquity:
    image: linuxserver/ubooquity:71
I guess you could get around this by including a premade webmin.cred file ( /opt/appdata/ubooquity/webadmin.cred ) and let users change the password - similar to how the backup/restore function works, or you could make a two step process, install old version first, set password, return to plexguide script, install with :latest tag.
 

barryclamsworth

Legendary Member
Donor
I did not experience this issue at all. I'm curious why you did and I did not. I am currently on version 76 and have not updated since installation.
No idea sorry, after I tried to add a password it just seemed to spin and spin and never completes. It also happened on my home server which is debian and using host network. Maybe I used illegal characters in my passwords.

Probably best ignored unless other people have issues I would think.
 

barryclamsworth

Legendary Member
Donor
The issues weren't from plexguide so don't be sorry - I clean installed independantly on my home server a month ago and ran into this problem (different passwords, no idea what each is but generated and will have special characters). The old versions worked fine. I found the solution online then but can't find where that was to link it here but I know it wasn't just me that had this timing out issue.

The only other thing I can think of that I have different is on both the home debian and neticup VPRS servers I have webmin installed. I haven't put it on my Hetzner VPS so I'll test it there when I get a chance, it only appeared in the plexguide installer a few days ago and wasn't there when I set up the hetzner vps.

One other thing I guess is I attempted to set an SSH key which is not being accepted when I try to connect on the neticup Ubuntu server.

Off topic: I feel a strong urge to add a dangling 1 to every post now just for Admin9705s pleasure.
 

pentaganos

Full Member
Woah this blew up :)

@AugusDogus With the permissions issue did you try create a "comics" folder in the root section of gdrive? I know this isn't in the guide or part of the PG script and it's something I overlooked.

If it still happens or if you have already done that just post here again and I will try from a fresh install.

Pent
 

Admin9705

Administrator
Project Manager
The issues weren't from plexguide so don't be sorry - I clean installed independantly on my home server a month ago and ran into this problem (different passwords, no idea what each is but generated and will have special characters). The old versions worked fine. I found the solution online then but can't find where that was to link it here but I know it wasn't just me that had this timing out issue.

The only other thing I can think of that I have different is on both the home debian and neticup VPRS servers I have webmin installed. I haven't put it on my Hetzner VPS so I'll test it there when I get a chance, it only appeared in the plexguide installer a few days ago and wasn't there when I set up the hetzner vps.

One other thing I guess is I attempted to set an SSH key which is not being accepted when I try to connect on the neticup Ubuntu server.

Off topic: I feel a strong urge to add a dangling 1 to every post now just for Admin9705s pleasure.
ya i could never get it to work
 

Admin9705

Administrator
Project Manager
I did not experience this issue at all. I'm curious why you did and I did not. I am currently on version 76 and have not updated since installation.
Any luck on this one? figured it, it was because you have to goto that very specific link
 
Last edited:

indochild

Full Member
I can't seem to point Ubooquity to the correct folder. I created the comics folder in gdrive and populated it, but ubooquity only has /comics not /unionfs/comics and when i browse for the correct folder i can't find it.

---- Automatically Merged Double Post ----

nevermind forgot to check the volume in portainer. it was defaulted as mnt/unionfs/plexguide/ubooquity/comics

DUH!o_O
 
Last edited:

Derfla76

Full Member
One thing I noticed is that the wiki settings are for usenet mostly, but since I use torrents more than anything of late, Mylar will send the torrent over (if it finds it) and download it fine, but nothing in the wiki addresses Mylar actually going back and looking for what was downloaded.

View attachment 915

Above I have gone to the quality and post-processing tab and selected to have Mylar monitor where I have my torrent client place completed downloads once they are done.

But in order for this to work I also have to map this folder in the Mylar container first.

Once I do this and Mylar does it's post process I can see the files copy and rename and move to GDrive.

Now I could TOTALLY be wrong and missed something somewhere. This is just my experience with what I have to do. Because I keep losing the settings when I update the container.
 

I_HATE_LOGINS

Junior Member
The password issue is because some idiot chose to encrypt the password on the client. It is bad practice on the extreme side. You cannot validate encrypted input.

Code:
angular.min.js:117 TypeError: Cannot read property 'length' of undefined
    at str2rstr_utf8 (sha256-min.js:10)
    at hex_hmac_sha256 (sha256-min.js:10)
    at password.js:18
    at angular.min.js:130
    at n.$eval (angular.min.js:144)
    at n.$digest (angular.min.js:142)
    at n.$apply (angular.min.js:145)
    at l (angular.min.js:97)
    at H (angular.min.js:101)
    at XMLHttpRequest.u.onload (angular.min.js:102)
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Development Donations

 

Online statistics

Members online
5
Guests online
87
Total visitors
92
Top