What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Solved messed up upgrade, please help

Status
Not open for further replies.

brichard

Junior Member
PG Version
GDrive - 6.014
Server Type
Remote - Dedicated Server
Hi All,

I am on GDrive - 6.014 and recently tried to upgrade via pgupdate, was getting an error
rm: cannot remove '/opt/plexguide/menus/version/main.sh' - protected (?)

So I have removed it manually, which turned out being a stupid idea as now I am getting:
rm: cannot remove '/opt/plexguide/menus/version/main.sh': No such file or directory
bash: /opt/plexguide/menus/version/main.sh: No such file or directory

What can I do to preserve my config and files and fix this and/or upgrade to the current version?

(Seemingly everything is still running fine)
 

brichard

Junior Member
Did you use sudo ?!?
For the upgrade not sure, probably didn't as I assume from your answer that would have resolved it...
Then couldn't delete with sudo user, so deleted as root...

Tried to reinstall
sudo apt-get update -y && sudo apt-get install wget -y && sudo wget https://plexguide.com/install.sh && sudo bash ./install.sh
Didn't resolve it.

Can I reinstall somehow?
What is the file I have removed? Something major I would assume.
 

brichard

Junior Member
Thank you, the file is back now and I am back to the original issue.

I am logged in with the user I have created during install.
sudo pgupdate - nothing visible happens
pgupdate - permission issue

Should I do it as root?

Code:
[email protected]:~$ sudo pgupdate
[email protected]:~$ pgupdate
rm: remove write-protected regular empty file '/opt/plexguide/menus/version/main.sh'? y
rm: cannot remove '/opt/plexguide/menus/version/main.sh': Permission denied
[email protected]:~$
 

beats

Full Member
Staff
sudo is root as such so I dont think it will be that.
I am not sure exactly what could be wrong as I did not run that version tbh.
 

brichard

Junior Member
This is all I see in the log after sudo pgupdate if it helps.

Code:
26/10/2018 15:46:38 INFO - Installing: Start Execution of PG YML GEN Script
26/10/2018 15:46:38 INFO - YML List Generated @ /var/plexguide/yml.list
26/10/2018 15:46:38 INFO - Installing: Exiting PG YML GEN Script
 

brichard

Junior Member
Would you recommend an uninstall/reinstall?
Can I keep my settings and containers running if I do that and should I reinstall the same version and then upgrade or could I install the latest?
 
Assists Greatly with Development Costs
Status
Not open for further replies.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
5
Guests online
125
Total visitors
130
Top