What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

issues installing nzbget-mp4

ch1p2014

Respected Member
hey guys tried installing nzbget-mp4 on a working system gets as far as :

TASK [Waiting for nzbget to initialize] ****************************************
Wednesday 27 March 2019 21:23:02 +0100 (0:00:08.496) 0:00:14.459 *******
fatal: [127.0.0.1]: FAILED! => {"changed": false, "elapsed": 300, "msg": "Timeout when waiting for file /opt/appdata/nzbget/nzbget.conf"}
to retry, use: --limit @/opt/communityapps/apps/nzbget-mp4.retry

so decided to format server and try again only getting same results :(

ubuntu 18.04 lts

cheers
 

FullCycle

Full Member
Hi Chip,

What version of PG are you using?

It sounds like it could be waiting for it to build the ffmpeg before launching the app. But the ansible script is timing out beforehand.

As a test, if you run:
touch /opt/appdata/nzbget/nzbget.conf
To create the file, then deploy, that should tell us if that's the case.
If it does deploy then, then that is the problem. But it may have then missed setting some 'first run' config settings for nzbget.

Let me know, either way, as I can then modify the deploy script to workaround.

Alternatively, deploy normal nzbget first, to create initial config file with correct first run settings. Then deploy nzbget-mp4 over the top of it.

Altering the timeout would be guesswork, as different systems would take different times to build
 

ch1p2014

Respected Member
hmm ok after creating the nzbget.conf it now completes setup, but now im getting :-
Error: 503 Service Unavailable
It does say its running in docker, here is log from docker ....



Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests[security]) (3.0.4)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/lib/python2.7/site-packages (from requests[security]) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests[security]) (2019.3.9)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests[security]) (1.24.1)
Requirement already satisfied: cryptography>=1.3.4; extra == "security" in /usr/lib/python2.7/site-packages (from requests[security]) (2.6.1)
Requirement already satisfied: pyOpenSSL>=0.14; extra == "security" in /usr/lib/python2.7/site-packages (from requests[security]) (19.0.0)
Requirement already satisfied: cffi!=1.11.3,>=1.8 in /usr/lib/python2.7/site-packages (from cryptography>=1.3.4; extra == "security"->requests[security]) (1.12.2)
Requirement already satisfied: six>=1.4.1 in /usr/lib/python2.7/site-packages (from cryptography>=1.3.4; extra == "security"->requests[security]) (1.12.0)
Requirement already satisfied: ipaddress; python_version < "3" in /usr/lib/python2.7/site-packages (from cryptography>=1.3.4; extra == "security"->requests[security]) (1.0.22)
Requirement already satisfied: asn1crypto>=0.21.0 in /usr/lib/python2.7/site-packages (from cryptography>=1.3.4; extra == "security"->requests[security]) (0.24.0)
Requirement already satisfied: enum34; python_version < "3" in /usr/lib/python2.7/site-packages (from cryptography>=1.3.4; extra == "security"->requests[security]) (1.1.6)
Requirement already satisfied: pycparser in /usr/lib/python2.7/site-packages (from cffi!=1.11.3,>=1.8->cryptography>=1.3.4; extra == "security"->requests[security]) (2.19)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: requests-cache in /usr/lib/python2.7/site-packages (0.4.13)
Requirement already satisfied: requests>=1.1.0 in /usr/lib/python2.7/site-packages (from requests-cache) (2.21.0)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests>=1.1.0->requests-cache) (3.0.4)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/lib/python2.7/site-packages (from requests>=1.1.0->requests-cache) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=1.1.0->requests-cache) (2019.3.9)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=1.1.0->requests-cache) (1.24.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: babelfish in /usr/lib/python2.7/site-packages (0.5.5)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: guessit<2 in /usr/lib/python2.7/site-packages (1.0.3)
Requirement already satisfied: babelfish>=0.5.5 in /usr/lib/python2.7/site-packages (from guessit<2) (0.5.5)
Requirement already satisfied: stevedore>=0.14 in /usr/lib/python2.7/site-packages (from guessit<2) (1.19.1)
Requirement already satisfied: requests in /usr/lib/python2.7/site-packages (from guessit<2) (2.21.0)
Requirement already satisfied: python-dateutil>=2.1 in /usr/lib/python2.7/site-packages (from guessit<2) (2.8.0)
Requirement already satisfied: six>=1.9.0 in /usr/lib/python2.7/site-packages (from stevedore>=0.14->guessit<2) (1.12.0)
Requirement already satisfied: pbr>=1.8 in /usr/lib/python2.7/site-packages (from stevedore>=0.14->guessit<2) (5.1.3)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /usr/lib/python2.7/site-packages (from requests->guessit<2) (3.0.4)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/lib/python2.7/site-packages (from requests->guessit<2) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests->guessit<2) (2019.3.9)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests->guessit<2) (1.24.1)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: subliminal<2 in /usr/lib/python2.7/site-packages (1.1.1)
Requirement already satisfied: six>=1.9.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (1.12.0)
Requirement already satisfied: guessit<2.0,>=0.9.1 in /usr/lib/python2.7/site-packages (from subliminal<2) (1.0.3)
Requirement already satisfied: babelfish>=0.5.2 in /usr/lib/python2.7/site-packages (from subliminal<2) (0.5.5)
Requirement already satisfied: stevedore>=1.0.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (1.19.1)
Requirement already satisfied: beautifulsoup4>=4.2.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (4.7.1)
Requirement already satisfied: dogpile.cache>=0.5.4 in /usr/lib/python2.7/site-packages (from subliminal<2) (0.7.1)
Requirement already satisfied: enzyme>=0.4.1 in /usr/lib/python2.7/site-packages (from subliminal<2) (0.4.1)
Requirement already satisfied: chardet>=2.3.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (3.0.4)
Requirement already satisfied: requests>=2.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (2.21.0)
Requirement already satisfied: pysrt>=1.0.1 in /usr/lib/python2.7/site-packages (from subliminal<2) (1.1.1)
Requirement already satisfied: click>=4.0 in /usr/lib/python2.7/site-packages (from subliminal<2) (7.0)
Requirement already satisfied: python-dateutil>=2.1 in /usr/lib/python2.7/site-packages (from guessit<2.0,>=0.9.1->subliminal<2) (2.8.0)
Requirement already satisfied: pbr>=1.8 in /usr/lib/python2.7/site-packages (from stevedore>=1.0.0->subliminal<2) (5.1.3)
Requirement already satisfied: soupsieve>=1.2 in /usr/lib/python2.7/site-packages (from beautifulsoup4>=4.2.0->subliminal<2) (1.9)
Requirement already satisfied: decorator in /usr/lib/python2.7/site-packages (from dogpile.cache>=0.5.4->subliminal<2) (4.4.0)
Requirement already satisfied: idna<2.9,>=2.5 in /usr/lib/python2.7/site-packages (from requests>=2.0->subliminal<2) (2.8)
Requirement already satisfied: certifi>=2017.4.17 in /usr/lib/python2.7/site-packages (from requests>=2.0->subliminal<2) (2019.3.9)
Requirement already satisfied: urllib3<1.25,>=1.21.1 in /usr/lib/python2.7/site-packages (from requests>=2.0->subliminal<2) (1.24.1)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3" in /usr/lib/python2.7/site-packages (from soupsieve>=1.2->beautifulsoup4>=4.2.0->subliminal<2) (1.5)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Requirement already satisfied: qtfaststart in /usr/lib/python2.7/site-packages (1.8)
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Uninstalling stevedore-1.19.1:
Successfully uninstalled stevedore-1.19.1
DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.
Collecting stevedore==1.19.1
Using cached https://files.pythonhosted.org/packages/da/e6/d99d56472152055c71c94cf0e1f46b2d47b285ad068a6d6302a5c73d7e4b/stevedore-1.19.1-py2.py3-none-any.whl
Requirement already satisfied: six>=1.9.0 in /usr/lib/python2.7/site-packages (from stevedore==1.19.1) (1.12.0)
Requirement already satisfied: pbr>=1.8 in /usr/lib/python2.7/site-packages (from stevedore==1.19.1) (5.1.3)
Installing collected packages: stevedore
Successfully installed stevedore-1.19.1
ffmpeg-build-script-downloader v0.1
=========================================

First we create the ffmpeg build directory ffmpeg-build
Now we download and execute the build script

ffmpeg-build-script v1.1
=========================

Using 12 make jobs simultaneously.

building yasm
=======================
yasm already built. Remove /config/ffmpeg-build/packages/yasm.done lockfile to rebuild it.

building nasm
=======================
build-ffmpeg: line 179: cd: /config/ffmpeg-build/packages/nasm-2.14.02: No such file or directory
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[ERROR] Could not read configuration templates
[INFO] nzbget 20.0 server-mode
[INFO] Scheduler: unpausing download
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /
[WARNING] Web-Server: 503 Service Unavailable, Resource: /

cheers
 

captngimpy

Senior Member
Staff
you could manually enter the container and build ffmpeg that what I did to find out that 2.13 was not working with gcc 8. You would want to edit the /opt/appdata/nzbget/ffmpeg-build/build-ffmpeg/ and change the line that i referenced up top. And then in portainer go to the commandline for nzbet and run /config/installer/installer.sh
 

FullCycle

Full Member
I see you have made a commit to use the default aac encoder too, rather that the libfdk_aac encoder.

For this, a custom build of ffmpeg is not needed, but can result in glitching audio.

Also, embedded subs in mp4 files can made incompatibilities with many players.
 

captngimpy

Senior Member
Staff
so ios-audio is a setting that needs to be true or false and then audio-codec you would specify libfdk_aac to use the codec first
audio-codec = ac3,mp3,dts,dca,aac,libfdk_aac is what is currently in there. I didn't make any changes to that.
 

FullCycle

Full Member
ios-audio= can be true (=encode aac stereo and put it as first track), false (=don't create aac stereo and put it as first track), or a specific codec, eg libfdk_aac (encode stereo with this codec and put it as first track).

So this is the part setting which codec to use for the encode.

audio-codec= specifies the desired, or allowed codecs. If a track with one of these codecs is present in the file, it gets re-muxed/copied through to the mp4. If there is a track with a codec not in the list, it gets re-encoded to the first option and the original track removed.

So if we set libfdk_aac as audio-codec, it would use that to create a 5.1 aac track from a ac3 5.1 track (if ac3 is not in the list). But if I have a AV amp at home, I am likely to be able to passthrough a 5.1 ac3 track to it anyway. So we don't need to do that.

The important part is setting the audio codec in the ios-audio= section, as this is where the codec choice for the stereo downmix on first track goes.

Also, you only get a correct downmix by also setting this together with the dialogue normalisation filter (dialnorm), in the relaxant section. Otherwise, it just passes through the front L & front R channels. The centre channel, which contains most of the dialogue, is skipped, and so you hear all the effects and very little of any speaking.

Hope that all makes sense.
 

captngimpy

Senior Member
Staff
@FullCycle Ok I miss read the readme then. I swear I was getting errors thrown if it was anything other then true or false though.

So we would want to set ios-audio=libfdk_aac.

We want to not embed subs and probably then grab a srt file intead of doing the mov_text.

I'm currently making edits to submit a pull request. so any thing else let me know and I'll throw them in.

If i remember correctly the config file doesn't point to the right directory for MP4_Automator. I can't remember though for sure but I thought it pointed to /sickbeard_mp4_automator instead of /config/scripts/MP4_Automator
 
Last edited:

ch1p2014

Respected Member
not good news ... redeployed and still the same - gets stuck on install in same place :-

fatal: [127.0.0.1]: FAILED! => {"changed": false, "elapsed": 300, "msg": "Timeout when waiting for file /opt/appdata/nzbget/nzbget.conf"}

if i touch /opt/appdata/nzbget/nzbget.conf it completes setup but not sure what is happening then as i get Error: 503 Service Unavailable
please advise
 

captngimpy

Senior Member
Staff
It could be since the docker is taking longer to fully start because its building ffmpeg and we are only using a delay of 5 mins before checking to see if the nzbget.conf is created. Thats the only this i can think of.
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Online statistics

Members online
15
Guests online
99
Total visitors
114
Top