What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Solved IP address problem when creating docker container with docker-compose

Status
Not open for further replies.

macfreaker

Blitz Sergeant
PG Version
7.1.7
Server Type
Remote - VPS
I have created a docker compose file but after starting the container I can't connect to the container.
I have followed the guide on the link below to create a docker compose file.
Example on this forum

My docker compose file has this file as example but I don't get an internal IP address. I post my docker file here so that someone maybe sees why I don't get a IP address.
Code:
---
version: '2'
services:
  xteve:
    image: crobibero/xteve:latest
    restart: always
    container_name: xteve
    labels:
      traefik.enable: "true"
      traefik.frontend.auth.basic.users: ""
      traefik.docker.network: "plexguide"
      traefik.frontend.redirect.entryPoint: "https"
      traefik.frontend.rule: "Host:xteve.example.com,"
      traefik.port: "34400"
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/home/xteve/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
Docker compose gives no error and is starting normal but as you can see in the picture below there is no ip address, while in the example of the link above there is a IP address.
I also don't see my configured port (34400) in portainer.

Screenshot 2018-11-26 at 18.58.00.png

I have seen that the container crashes but don't know why.

ezgif.com-video-to-gif.gif
 
Last edited:

macfreaker

Blitz Sergeant
I have found the solution for this problem that I had:
  1. There was a problem with the docker container, so I use now another container and this works.
  2. The Traefik labels can not be used in the docker-compose.yml file for this container / app. I've removed these lines and it was ok.
Here is the docker-compose.yml that I use now and that is working.

Code:
---
version: '2'
services:
  xteve:
    image: bl0m1/xtevedocker:latest
    restart: always
    container_name: xteve
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/root/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
Screenshot 2018-11-27 at 14.05.23.png
 

macfreaker

Blitz Sergeant
I don’t have directly a guide. But I have written a new composer file for PlexGuide where you can place the file in and do the install within the PlexGuide menu. I will see in a few days to post it.
 

dishjuarez

Blitz 1st Class
I don’t have directly a guide. But I have written a new composer file for PlexGuide where you can place the file in and do the install within the PlexGuide menu. I will see in a few days to post it.
hello had days that did not enter the forum and I find your post and I see that you have the solution to this problem, I tried to install xteve but it happened to me the same thing did not work, what did you do exactly? I thank you very much in advance.
 

skijbal

Blitz 1st Class
I have found the solution for this problem that I had:
  1. There was a problem with the docker container, so I use now another container and this works.
  2. The Traefik labels can not be used in the docker-compose.yml file for this container / app. I've removed these lines and it was ok.
Here is the docker-compose.yml that I use now and that is working.

Code:
---
version: '2'
services:
  xteve:
    image: bl0m1/xtevedocker:latest
    restart: always
    container_name: xteve
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/root/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
View attachment 2266
I’ve tried this yml and it keeps erroring on line 2.
 

Admin9705

Administrator
Project Manager

SirTranceALoT

Blitz Samurai
Staff
I was late to this thread to. Testing now.

Screenshot 2018-12-28 11.44.30.png
 
Last edited:
Assists Greatly with Development Costs

SirTranceALoT

Blitz Samurai
Staff
OK, working now. For some reason, I had to manually correct it while it was ok in the yml file. some be very carefull when copy/pasting.
 

SirTranceALoT

Blitz Samurai
Staff
For some reason, it copied this part
Code:
#!/bin/bash
#
# Title:      PlexGuide (Reference Title File)
# Author(s):  Admin9705
# URL:        https://plexguide.com - http://github.plexguide.com
# GNU:        General Public License v3.0
################################################################################
---
- hosts: localhost
Like this

Code:
#!/bin/bash
#
# Title:      PlexGuide (Reference Title File)
# Author(s):  Admin9705
# URL:        https://plexguide.com - http://github.plexguide.com
# GNU:        General Public License v3.0
################################################################################
--- -
 hosts: localhost
 
Status
Not open for further replies.

Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Top