What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Indirect connection, docker portforwarding? <SOLVED>

Fr4nsson

Blitz 3rd Class
I've been trying for about 7 hours to get my plex server to go from indirect to direct connection, i had no problem on windows but then i reformatted and installed Linux because i wanted to try out plexguide and now i cant get a direct connection, is it because of docker? it gives me another IP address 172... instead of 192... do i need to port forward within docker too?

would appreciate help, im new with linux
 

Admin9705

Administrator
Project Manager
here is what you should do. get a cloud vm instance with https://hetzner.cloud from there, test things on there for a sanity check. this will help bounce against what your doing. the cloud vm instance is cheap.
 

Fr4nsson

Blitz 3rd Class
Ok but just to be sure, do i need to portforward within linux or docker from a fresh ubuntu desktop install with just plexguide on it? or should it just work?
 

foolio

Blitz 1st Class
Patron
for a local setup you should need to portforward from your router to the host ip (or vm ip) running PGBLITZ (formerly plexguide) at least port 80, and 443 for traefik then for plex you need to forward whatever port plex is setup to use i.e. 32400
 

Fr4nsson

Blitz 3rd Class
I couldnt get it to work so i had to install it with plex own installer (in other words not with plexguide) and it worked instantly, but for me thats perfect since i only needed plexguide to set me up with googledrive anyway because im only interested in plex and gdrive and im fine fiddling with the media manually. Thanks for the help tho :)
 
M

MrDoob

Guest
10.seconds Google.

What network ports do I need to allow through my firewall?
The most important port to make sure your firewall allows is the main TCP port the Plex Media Server uses for communication:
  • TCP: 32400 (for access to the Plex Media Server) [required]
The following ports are also used for different services:
  • UDP: 1900 (for access to the Plex DLNA Server)
  • TCP: 3005 (for controlling Plex Home Theater via Plex Companion)
  • UDP: 5353 (for older Bonjour/Avahi network Sitevery)
  • TCP: 8324 (for controlling Plex for Roku via Plex Companion)
  • UDP: 32410, 32412, 32413, 32414 (for current GDM network Sitevery)
  • TCP: 32469 (for access to the Plex DLNA Server)


for testing the ports :


IP > your ISP IP
Port > see top
 

Fr4nsson

Blitz 3rd Class
Yes but in my case it seems the ports was not the issue since it just worked instantly when i installed plex manually instead of the plexguide installer, so i think my problem was something with docker and its internal ip system. My problem is solved now anyway, so im happy.
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Development Donations

 

Top NZB NewsGroups!

Members - Up To a 58% Discount!

Trending

Members online

Top