What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion HTTPS not forced for top level domain app

CyborgPirate

Respected Member
PG Version
7.5.4
Server Type
Remote - Dedicated Server
I recently installed v7.5.4 and decided to move plex to the top level domain app using the traefik program in plexguide.
I have noticed that the when visiting my top level domain, https is not enforced. With all other subdomains http is rerouted to https without me having to configure anything.

Just to clarify I did not used to use the top level domain for any plexguide apps so I dont know if this is an old problem or a new one.

Other than that I am loving the 7.x releases. Keep up the good work!

Edit: incase it is important I am running a brand new install of debian 9 on a hetzner machine
 
Last edited:

CyborgPirate

Respected Member
I recently installed v7.5.4 and decided to move plex to the top level domain app using the traefik program in plexguide.
I have noticed that the when visiting my top level domain, https is not enforced. With all other subdomains http is rerouted to https without me having to configure anything.

Just to clarify I did not used to use the top level domain for any plexguide apps so I dont know if this is an old problem or a new one.

Other than that I am loving the 7.x releases. Keep up the good work!

Edit: incase it is important I am running a brand new install of debian 9 on a hetzner machine

Edit2: it seems that it's just Plex as far as I can tell. Plex is my top level domain which is not forcing Https and also plex.domain.com is not Https either
 

meteo

Respected Member
Staff
Do you use cloudflare?
Toggle setting for enable https rewrites.

Add a page rule for https://*domain.tld/*
bypass cache, force https rewrite, ssl full, disable apps.

if not using cloudflare i'm not sure,
options in plex to force certain domains/ports.
try change primary container, re-deploy & reboot.

dns setup like below on cloudflare
a record -> domain.tld ->server ip > ttl auto
a record -> * (wildcard, change orange cloud to grey) -> ip -> ttl auto
 
Last edited:

CyborgPirate

Respected Member
Do you use cloudflare?
Toggle setting for enable https rewrites.

Add a page rule for https://*domain.tld/*
bypass cache, force https rewrite, ssl full, disable apps.

if not using cloudflare i'm not sure,
options in plex to force certain domains/ports.
try change primary container, re-deploy & reboot.

dns setup like below on cloudflare
a record -> domain.tld ->server ip > ttl auto
a record -> * (wildcard, change orange cloud to grey) -> ip -> ttl auto
I do use cloud flare! This is a great solution. Thank you.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Top NZB NewsGroups!

Members - Up To a 58% Discount!

Development Donations

 

Online statistics

Members online
9
Guests online
131
Total visitors
140
Top