What's new
PGBlitz.com

Register Now! Find useful tips, Interact /w Community Members and join the part the Best Community on the Internet!

Discussion Added Support for hardware transcoding on Linux with Intel 9th-gen processors. Intel i9900??? EX62??

benamira

Junior Member
Donor
According to the release notes of the latest PMS Server version it seems that they have added Support for hardware transcoding on Linux with Intel 9th-gen processors.
It could probably open the possibility to the high-end Hetzner Server as the EX62-NVME with the awesome intel i9900.

 

iamsith

Junior Member
Donor
Indeed, I am running this server with the beta and it's working fantastic, simply change the docker tag so its plexinc/pms-docker:plexpass instead of plexinc/pms-docker:latest and you'll be off to the races. As soon as I saw it posted I swapped it and fired up a 4k transcode to 1080p 8mbps just to see the cpu sit at 5% utilization!
 

johnsmith66

Junior Member
How du you install the correct driver? I do have the EX62-NVME hetzner server. I did install drivers manually following this guide: https://pgblitz.com/threads/hw-transcoding-from-docker-solution-for-hetzner-dedicated-and-info-for-other-servers.2544/

ls -la /dev/dri
total 0
drwxr-xr-x 3 root root 100 Sep 19 07:55 .
drwxr-xr-x 19 root root 4040 Sep 19 07:55 ..
drwxr-xr-x 2 root root 80 Sep 19 07:55 by-path
crw-rw---- 1 root video 226, 0 Sep 19 07:55 card0
crw-rw---- 1 root video 226, 128 Sep 19 07:55 renderD128


When i'm running vainfo I get this:

error: can't connect to X server!
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva error: /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

So anybody here to guide me in the right direction? Thanks.
 

iamsith

Junior Member
Donor
I didn't have to do any of that, all that I had done was through the pgblitz menu and do the hetzner igpu setup, then in plex I set the transcoder setting to use hardware whenever available and it just worked. Maybe I just got lucky with something but I can confirm that it is using hardware transcoding now.
 

UncleBuck

Senior Member
Staff
I have been on the EX62-NVME for a couple of months now. I had set up for hardware transcoding when I first set up this server but of course, it didn't work as Plex didn't support it yet. Well after seeing this post I checked and transcodes are now reporting as HW. I don't recall my exact steps but pretty sure I just used the option in the PGBlitz menu.

I have tested 4K transcoding and the results are simply awesome. At this moment there are 4 people streaming. Three are transcoding from 1080p, one to 720p and two to 480. I am running a test 4k transcode all the way down to 480. My current processor usage is sitting at around 8%. This far exceeds my expectations. So much that I am merging my 4k movie library into my main movie library and will change my radarr profile to allow 4k versions of all future downloads. Now I just need to get all my users to change their default quality settings so they can reap the benefits of 4k.
 

UncleBuck

Senior Member
Staff
@johnsmith66 So I had to wipe my server and start from scratch and now I am getting the same issue with setting up HW transcoding that you had. I ran through the pgblitz menu to set it up but that didn't work. I ran through the manual process you mentioned but still no go. I am getting the same error in vainfo, /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so init failed. Did you ever resole this?
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Top NZB NewsGroups!

Members - Up To a 58% Discount!

Development Donations

 

Online statistics

Members online
7
Guests online
86
Total visitors
93
Top