PG News 8.6 Changelog

Assists Greatly with Development Costs
Status
Not open for further replies.

Admin9705

Administrator
Original poster
Project Manager
5,819
2,008
8.6.1 – 8.6.3 – 9 May Change



Cache mode added to PGBlitz – See pull request @ https://github.com/PGBlitz/PGClone/pull/24Visit settings under PGBlitz to change the values!For it to go into affect, please REDEPLOY the mounts.







8.6.1 – 8.6.3 – 2 May Changes



PG Move now utilizes same cleanup script as pgblitzRedeploy PG Move to take affectChanged a default value (VFS-Cache-Max-Age to 1h instead of 168) in pgblitz’s rclone variables interface; so new tv shows read properly when added. Only takes effect on new installs. If using blitz already, just change it via the options if your having problems with new shows playing.Redeploy pgblitz if making a manual change



8.6.1 – 8.6.3 – 30 April Changes



PGBlitz tweaks. Improved removing garbage files and empty folders. Reference 8.6.2 – 27 April post in regards to menu interface. To take affect...
Continue reading...
 
Last edited:
  • Like
Reactions: pYTTH

TheShadow

Blitz 1st Class
Staff
51
16
Note: Not my user/domain.... The project has 8 keys attached.

[1] Transport Select | INFO: Change Transport Type
[2] Destroy All Service Keys | WARN: Wipes All Keys for the Project
[3] Create New Project | WARN: Resets Everything
[4] Demo Mode - OFF | Hide the E-Mail Address on the Front
[Z] Exit

NOTE: When creating a NEW PROJECT (option C), the USER must create the
CLIENT ID and SECRET for that project! We will assist in creating the
project and enabling the API! Everything reets when complete!

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
↘ Input Selection | Press [ENTER]: 2
ERROR: (gcloud.iam.service-accounts.list) Your current active account [xxx] does not have any valid credentials
Please run:

$ gcloud auth login

to obtain new credentials, or if you have already logged in with a
different account:

$ gcloud config set account ACCOUNT

to select an already authenticated account to use.

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
🚀 Error! Nothing To Delete!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

NOTE: No Accounts for Project ~ dfsdfsdf01
are detected! Exiting!
 
Last edited by a moderator:
  • Like
Reactions: Admin9705

TheShadow

Blitz 1st Class
Staff
51
16
It did not delete the service accounts on the gdrive site, so I did it manually.

I'm at the tested - works but "deploy not ready" phase.

Oops, my blitz is broken w/o a deploy b/c I deleted the service keys and made new ones. Any chance we could fast track that part?
Failed to create file system for destination "gdsa01:/": didn't find section in config file

You should also mention in the email generator menu to share via gdrive site as "Content Manager" wasn't very clear. When will the deploy be ready?
 
Last edited:

Admin9705

Administrator
Original poster
Project Manager
5,819
2,008
when it is; working pgmove first because it's easy; but rewriting the code for that also. making it more simple and less complex. for pgblitz, i have some ideas on how data moves... but the feedback you provide helps because it's executed better when the final version is done. have you notice an increase in speed and etc from the rest?
 

TheShadow

Blitz 1st Class
Staff
51
16
what do you mean speed? I can't use it yet b/c deploy doesn't work yet. It looks to be a bit more user friendly but needs some polish.
 
  • Like
Reactions: Admin9705

timekills

Blitz General
Staff
Donor
414
174
8.5 did this as well; running pgblitz as root activated the expected top level script, while running as a user, whether sudo or not displayed the blitz logs. I just usually executed sudo plexguide but figured I'd second the comment.
 
  • Sweat
Reactions: Admin9705

vFlagR

Blitz 2nd Class
32
15
8.6.test3 all tests passed for PgBlitz unencrypted. Process seems more streamlined and definitely quicker.

Will this release sort issues where files aren't removed after being moved to tdrive? Having to log in to my server every couple of days now and clear /mnt/downloads/nzbget manually because it's filling up with files that have been "moved" to tdrive.

Thanks for all the hard work as always, happy to test anything further around PgBlitz :)
 
  • Money
Reactions: Admin9705

TheShadow

Blitz 1st Class
Staff
51
16
Have you checked the sonarr/radarr logs first to determine if it downloaded duplicates and didn't import b/c quality/size/already exists/etc?

That's 100% of the cases for me when I see downloads 'stuck'. First I check History and activity tabs, look for yellow or red icons, then I do a manual import on /mnt/unionfs/[downloader]/[category] and check again. Most of the time I'll see episode on disk is same quality or higher etc. Turns out sab unpacked the same file 3 times and the directory was /mnt/downloads/sabnzbd/tv/download.1 and download.2 and download.3. Sometimes I run search all a few times a week w/o clearing the queue and it downloads the same thing twice.

The other time is when I rebooted the server or stopped the arr container in the middle of processing.

I would double check your download mappings under download client settings in radarr/sonarr and make sure they are right b/c that will cause files being copied and not moved if it's not done properly...

Try updating to the latest 8.5.x on your prod server then redeploy your mounts, I do see some "access denied" fixes recently went in!
 

bdunn

Blitz 3rd Class
23
5
I have two PGs deployed. Heavy lifting at GCE and a simpler one at my site. The one at my site was having issues so I ripped out PlexGuide to replace with 8.6test3. I noticed during the install just following the name of the site ID, not to change the processing disk, and having Watchtower update everything but Plex/Emby I saw this during processing:

fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": "cat /var/plexguide/server.ports", "delta": "0:00:00.002648", "end": "2019-03-14 11:31:17.469413", "msg": "non-zero return code", "rc": 1, "start": "2019-03-14 11:31:17.466765", "stderr": "cat: /var/plexguide/server.ports: No such file or directory", "stderr_lines": ["cat: /var/plexguide/server.ports: No such file or directory"], "stdout": "", "stdout_lines": []}
 

Admin9705

Administrator
Original poster
Project Manager
5,819
2,008
got it, ya it's the name set piece. have to work a new solution for that. doesn't break anything. server name is just needed for backup and restores. name can be set in pgvault.
 

Admin9705

Administrator
Original poster
Project Manager
5,819
2,008
correct, plus using your old ones will not work. there is a new structure how the keys are built. if you want to test, just build 2 keys. won't impact your other keys for 8.5
 
  • Like
Reactions: timekills

Nigel

Blitz Sergeant
Staff
Donor
137
40
I'm really good and you? Yeah I am using PGBlitz now and it is amazing. Previous year I had to make the servide keys by myself. Now its more automatic. Your doing a great job!
 

nachobel

Blitz Sergeant
Staff
Donor
127
27
This has been working - it was mostly my misunderstanding of the file system not anything actually wrong. LMK if you've still got questions - things should be copying and not moving :D
 

Uy9KC7OP2R2yn6TZVSMP

Blitz 2nd Class
Staff
43
37
Hey thanks a lot for the reply! I'll start by carefully reviewing the doc, my configuration etc and if it's still copying, I'll reach out :)

Edit: Although I'm on 8.5.8 , does this functionality require 8.6 ???
Edit2 : Nope, started on 8.3 so I should be good normally.
 
Last edited:

hooper

Blitz Samurai
Staff
Donor
312
112
seeing errors like this with the latest beta

WriteFileHandle: Can't open for write without O_TRUNC on existing file without --vfs-cache-mode >= writes
 
  • Like
Reactions: Admin9705

timekills

Blitz General
Staff
Donor
414
174
8.6beta2
@MrDoob The Hetzner iGPU/GPU script for testing (#4) calls the "pghetznerigpu.sh" from the wrong location.
It is in the "/opt/plexguide/menu/tools/hetzner" folder, but when run it looks in the "/opt/plexguide/menu/tools" folder.
Error it produces is:
bash: /opt/plexguide/menu/tools/pghetznerigpu.sh: No such file or directory
 

MrDoob

Administrator
Project Manager
Donor
1,459
420

MrDoob

Administrator
Project Manager
Donor
1,459
420
edit is done .. thanks again for the catch @timekills
 

timekills

Blitz General
Staff
Donor
414
174
@Admin9705 @MrDoob Also regarding HW encode in Plex - the last couple versions of the plex.yml have removed the passthrough of the /dev/dri folder. Without this being available in the Plex Docker container, hardware encode is not possible.

I see the code is supposed to check for existence:
- name: Check /dev/dri exists
stat:
path: '/dev/dri'
register: dev_dri


And then register as a device if it does:
devices: "{{ '/dev/dri:/dev/dri' if dev_dri.stat.exists == True | default(false) else omit }}"


However, it does not appear to show up in the docker container.
 
Last edited:

timekills

Blitz General
Staff
Donor
414
174
I'll take a look; ran into some issues on one of the newer i9 9900 systems but it's an Intel driver issue with the 9x series of CPUs.
I'm going to rebuild a known good system and see results, then I'll work any necessary updates to the script.
 
  • Love
Reactions: Admin9705
Status
Not open for further replies.

Similar threads


Development Donations

 

Trending